[RESPONDED] Using Framework 13 as a standalone PC with Samsung m8 monitor

Hello everyone, I am trying to use a framework 13 11th gen as as standalone PC hooked into a Samsung m8 smart monitor. The BIOS is at 3.19 btw
The monitor is 4k and only has usb c and micro hdmi as inputs. I am having so many issues with this project, but the main issue is the hdmi connection. I have the mainboard connected via an hdmi expansion card plugged into an hdmi cable to the monitor.

When connected and powered on when it is working properly, I get 4k 60hz with a 150% scale, but if I disconnect the hdmi and connect it back up, the display won’t come back and the monitor goes to sleep. the only way to get it to come back up is to unplug the computer and plug it back in, but then it won’t do 4k 60 anymore. It then is either 4k 30hz with no way to get it back to 60hz, or it defaults to 2k 60hz with no option to get it back to 4k 60. I am currently typing this from my orange pi 5 plugged into the monitor and it is getting 4k 60hz no problem.

What do you all think I can do?

Hi @Twilighttony ,

This may seem a redundant question, but what distro are you using?
and have you tried reproducing the issue with Ubuntu 22.04.4 Live and Fedora 39 Live?

Yeah, I’ve tried it with a Fedora 39 live iso and it also can’t get the 4k resolution.

FWIW, M8 and M7 Samsung Smart monitors does seem to have similar issues with Mac and OSX as well, and same work around applies by unplugging and re-plugging.