Rework Instructions for 11th Gen Mainboards to enable powering the RTC circuit from the main battery

Thanks for all your sympathies. I’ve been looking at the market and I think my most practical choice is to order an AMD board and re-use my existing shell. The fragile cradle, fragile threaded inserts, their failure to fix a critical defect (they designed a fix, but pushed actually fixing it off onto the customer), and their failure to fix the random thunderbolt disconnects when battery charge limit is below 100 that impacts 11th and 12th gen boards are all great reasons to not risk my money on more of their products but the alternatives are simultaneously twice as expensive while lacking key features.

For example, the StarBook was a close 2nd place, with similar availability of parts and the added feature of coreboot, but a minimum AMD build is $1400 and it has a low resolution screen and lacks hardware kill switches. Their larger StarFighter has kill switches but its far too large. On the framework side, the 11th and 12th gen boards are ruled out because 11th gen is defective and the 12th gen has the thunderbolt disconnect bug. That leaves the approximately equally priced 13th gen intel board and AMD boards, but considering all the issues the earlier Intel boards had, I figure its better to risk the unknown AMD board than hoping framework finally got the Intel boards right on the 3rd try.

Indeed. That leaves you with a laptop that every ~1.5 years without warning will refuse to boot which is not something I was willing to tolerate, but if someone is willing to tolerate that then its certainly the safest option.

I haven’t cleaned off the flux because its broken, so sorry that its a bit gross. The bottom pad came off (the one on the left-hand side of this photo). The top pad I think is still there under the solder but I could not for the life of me get that thing soldered to the cradle. The top pin on the cradle is entirely under the cradle plastic, not sticking out at all, so I was trying to sandwich my soldering iron between the pad and the pin.

Edit: ruh roh, maybe all frameworks have the disconnect bug. Well, I have an unknown quantity of weeks to decide if I want to cancel my pre-order: [RESOLVED] AMD F39 USB-C hiccups with external display directly connected via USB-C


One of the other early Framework 11 users was kind enough to do the soldering on my Framework 11 after I messed up. It works now, albeit with this kludge of a repair. Personally and professionally, Framework missed a chance to live up to their mission statement of being the most attentive to customers in the laptop business. They could have used liability insurance to pay for doing the rework, either at their facility or by outsourcing it to whomever. Their good is coming up with this fix. Their bad is leaving it to us early followers who loved the concept, loved the laptop and were bitterly disappointed to find it flawed and have been left swinging in the breeze. FWIW, Framework should not be too complacent about their decision to dump the board work onto end users. Liability law in California is worth looking at if you want to know more. As for myself. I got lucky.

1 Like

Is there some kind of a USB-C / Thunderbolt connection stability issues even with the 13th gen and AMD boards? I was hoping all power related issues would have been addressed by now (e.g. sleep / suspend, resume. For example, if I’m running a VM from a Thunderbolt drive via a TB dock, then suspend and resume the laptop, it shouldn’t kill my running VM)

I just finished the RTC circuit replacement on the two 11th Gen FW13s in our household. All in all, it went pretty smoothly - the second (my partner’s batch 1) took maybe 10 minutes total (from disassembly to replacement/solder to reassembly). The circuit is a tight fit into the coin cell socket, though - I cracked the socket on the first one (my machine) but I rigged up a fix. The second attempt went perfect, probably because I was more careful.
To solder, I put the solder on the tip (I used a generic “small” chisel tip), held the wire over the circuit with tweezers, and then just tapped the tip to the wire/circuit and lifted away, and repeated until the wire stuck. It only took two or three tries, and turned out pretty decent.
It is so nice to be able, after reassembly and before connecting power, to press the power button and have it finally turn on without first connecting it to power regardless of the battery status.


We also have a pair of 11 gen machines in our household that’ll have to go through this; not imminent, but in the foreseeable future, partly due to expected changes in usage patterns (not always feasible to keep plugged in).

This seems to have taken out quite a few cell holders, as reported on this thread. Any thoughts on ever so slightly reducing relevant dimension(s) of the circuit to mitigate this in new kits? @nrp

I’ve seen mentions of sanding down the lip of the component, it was upthread here I think.

1 Like

I recall Framework sending back this fake battery for rework as it was a bit too large for the holder. Perhaps the last go around they stopped tinkering with it

@Gary_S it would not have been an hour to solder the thing in if i had not broke the damm Battery holder. I really don´t like the handling of the situation.


Well, the 2 capacitors went “poof” on the second attempt to solder, so soldered to the underlying voltage regulator. It all works for now. As for how they handled this, as I have said before. Half full for coming up with a fix for their design flaw. The glass half empty for dumping the fix onto us early enthusiasts instead of using liability insurance to get it done in-house or pay for a repair shop.

I handled the holder oh so carefully. I recall it took me many minutes to gingerly work the fake battery into place, unlike taking out the original battery in seconds.

@Ian_Thomas :frowning: The socket is definitely the weak part of this operation. I also spent a significant amount of time on my FW13 (the first one I did the rework on) working something up after cracking mine. Thankfully the second one went much smoother, either due to increased diligence, familiarity, or even just variation in the parts.

If something could be done to reduce the diameter of the replacement just a bit it would go a lot smoother for folks, I think.

1 Like

Yes, the socket is a weak element and the fake battery a bit too big, but at this point I doubt that Framework will send it back for adjustment. Ah well.

The PCB dimensions are sized to make sure that the board makes good contact to the contacts, while still being possible to insert without breaking the receptacle. It can be neither larger nor smaller while satisfying those requirements. We tuned this carefully after several rounds of iteration. The reason an actual coin cell is easier to insert and remove is because coin cells have a rounded shape in 3 dimensions. A round PCB is just a cylinder. As folks have noted throughout this thread (and we emphasize in the Guide), you can insert the PCB without breaking the socket if you do so carefully, and you can also easily break the socket if you do not insert the PCB carefully.


A decent explanation, if not a mea culpa for not handling the fix in-house.

Again, please keep this topic on-track for rework instructions, experience, etc.
If you want to talk about “the issue” there are other threads to go find.


As far as I know the only forum for such discussion is on Reddit, not here. Are you a moderator or Framework employee?

No, but I am a moderator, and I’ve already warned the same thing in this topic at least twice.

Additional off-topic replies will be removed.


Sorry, never any intention to be off-topic regarding the fake coin battery fix.

1 Like

I did the rework on my two 11th gen Intel Frameworks. I’m two for two broken battery holders. I was incredibly careful trying to install the modules. It felt like the modules couldn’t fully get under even one side of the holder due to their thickness. I ended up doing this on both laptops:

Seems to work.

These bits broke off in both holders after I wedged the module under them and tried to push it down to get under the bottom half of the holder:

I broke the rest in order to remove it from the board.


More detail please. Not entirely sure my eyes are telling me how you did this.

Removed the broken battery holder plastic. Desoldered the lower battery contact. Covered the PCB with electrical tape to protect the traces. Soldered a short wire to the underside of the module. Soldered the other end of the wire to the lower contact solder point. The insulation of the wire protects it from touching the outer ring of the module, this preventing a short. Finally I soldered the outer ring of the module to the top battery contact. Finally I covered the module with a layer of electrical tape.


Hello, I have run into some issues and I want a sanity check before I give up hope.

I have broken off the battery holster and solder pad in a similar manner to Tom1. I tried to repair it by soldering directly to the trace. Then, I ripped off the entire trace, so it is a worse situation than him.

I use my mainboard as a server, so it will never go more than 1-2 hours without power (unless disaster strikes). However, there are some non-negotiable BIOS settings that must be set, so if the BIOS is reset with every unplug, then this is unusable for me. I use a strange software stack that requires a physical unplug of the motherboard rather than rebooting from the operating system.

I attempted the RTC repair so that I could use the main battery as a UPS, but I am willing to live without such a UPS if I can save my BIOS settings.

Am I out of luck?