Screen Brightness Automatically Changing

Hi Framework Community,

I’ve run into a potential bug. My screen will occasionally change brightness on its own despite having the Setting, “Change brightness automatically when lighting changes” un-selected. Is there another setting I’m unaware of that needs to be turned off also?

This appears to be un-related to the dim my screen setting in the power plan as it will occur while I’m actively using the laptop. It has occurred in low and well lit scenarios. I am not often in moderately lit environments to test this.

I’ve running the 1165-G7, 32GB 3200 ram, 1TB WD 750, 2 USB C, 2 USB A, webcam and microphone switches turned off, and Windows 10 Pro version 10.0.19043, build 19043.

Framework driver package was installed and all other aspects of the laptop function normally.

Anyone have any thoughts?

Check these settings in Start > Intel Graphics Command Center

Specifically, make sure “Adaptive Brightness” and “Display Power Savings” (adaptive contrast) are disabled.

3 Likes

Turns out I’ve never had that program turned on before and hadn’t even accepted the end-user-license agreement. So while I’ve turned those off does anyone think that they would be having that effect even if I hadn’t ever used them before? If so software taking action before the user has accepted the end-user-license agreement is a serious issue. Not saying this happened here, but just a thought that occurred. We’d need a lot more evidence before even being able to suggest such a thing within a legal context.

Intel has notoriously bad software.

Re: legality, this may be on Framework since I’m assuming their one-click automated drivers installer bypasses the user agreement prompts. I’m far from an expert on this subject though, just guessing.

I hope I’m wrong because it’d be annoying to have to press ‘agree’ for every single driver in the bundle installer.

Getting rid of that setting ng in the Intel software seems to have done it

I want to confirm that “Display Power Savings” that feesh describes as “adaptive contrast” is exactly the problem I had. Disabling it solved the “dimming” or “brightness” problem as I’d describe it. Thanks, feesh!

2 Likes