Setup disk unrecognized by BIOS

The mechanics were a breeze, except for the WIFI wires whose insertion is made difficult by neatly clipped thumbnails.

I have prepared a flashdrive with the two programs intended to download Windows 10 and install special drivers for my laptop.

I cannot get the EXFAT-prepared disk to be recognized. What was a brief look at the Framework opening logo, that is now but a blink of the eye.

Please help.

Did you make the flashdrive bootable or just put the Windows 10 ISO in it?

1 Like

Might be Secure Boot? That’s the first thing I think of, not sure that would be it since it’s Windows you’re trying to install but worth a shot

Is the USB recognized as a boot device in BIOS?

1 Like

I had the same issue with a drive formatted exFAT with an EFI (GPT) boot record.

I don’t know what the proper approach is - whether this would have worked with secure boot on or off - but I popped in a regular old FAT32 MBR USB stick and it worked like a charm.

Note: it did recognize the EFI/exFAT drive, it just wouldn’t boot from it. When I selected it nothing happened.

It will recognize and boot from it now that I disabled secure boot.

I suppose the thing to do is get into the BIOS first, disable secure boot, then try to boot from the drive. But the first boot menu came up before I could get into the BIOS.

@Fraoch I think it depends on what program you use to make the flashdrive bootable. I have used Rufus and you have to disable secure boot, but if you use the Windows Media Creation Tool then it will work with secure boot.


I think windows works better to boot FAT32 in EFI partition for flash drives when secured boot is turned on.

1 Like