[SOLVED] 13th Gen Intel Framework 13 running Fedora 38, media keys aren't working

I got my 13th Gen Intel Framework 13 this morning and installed Fedora 38 on it, however the multimedia keys seem to never be recognized … no matter what I do, it always registers as a function key. Not the end of the world but I thought it was kind of odd and was wondering if anyone else noticed this and might have a solution.

Thank you!

Have you tried doing the combo “Fn + Escape” to switch between function keys and media keys?
I did run into this when dual booting between Ubuntu and Windows… The default state seems to be different on installation (Ubuntu function keys on, windows media keys on by default or reverse), took me way too long to figured that… :sweat_smile:

Unfortunately the fn+escape didn’t fix it. However it seems to be a transient issue or something else is going sideways on me… on reboot the audio controls buttons are working fine but for some reason the display brightness keys still aren’t working. Which is fun. :confused: :thinking:

Same issue here. I’ve been using the stock Fedora 38 (upgraded from 37) with default Gnome for half a year. Since the last week only the brightness keys stopped working. All other media keys are fine.

Perhaps this guide helps.

Fedora 38 Installation on the Framework Laptop 13 - Framework Guides - Step 6 - Completing Setup - Enable brightness keys. You can also see https://community.frame.work/t/tracking-12th-gen-not-sending-xf86monbrightnessup-down/20605/11.

1 Like

All, when you’re making the purchase of a Framework 13, 13th gen, are you receiving an email with the links to the guides? I ask this as I believe those links are supposed to be going out, wanted to make sure they are as ideally everything you need should be in that email.

@Matt_Hartley have the guide links and have followed them. However, the modprobe configuration change doesn’t seem to work anymore in Fedora 38 on a Framework 13 (13th gen Intel Core i5).

EDIT: I also ran the grubby command to no avail.

Just to make sure, you ran this, rebooted and it did not work? Which kernel are you running?

sudo grubby --update-kernel=ALL --args="module_blacklist=hid_sensor_hub"

well nevermind, I did a kernel update this morning and now everything is working fine … it seems like the 6.2.9-300 kernel had an issue that the 6.3.12-200 doesn’t

Whomever has the power (or otherwise knows the proper discourse-fu) to close this thread as RESOLVED please feel free to do so. Thank you!

Yeah so I have it intermittently on kernel 6.3.12-200. I have the issue of the buttons not working it in this boot, so I checked my / proc / cmdline to check if it did boot with the module blacklisted:

cat / proc / cmdline
BOOT_IMAGE=(hd0,gpt2)/vmlinuz-6.3.12-200.fc38.x86_64 root=UUID=00000000-0000-0000-0000-000000000000 ro rootflags=subvol=root rd.luks.uuid=luks-00000000-0000-0000-0000-000000000000 rhgb quiet nvme.noacpi=1 module_blacklist=hid_sensor_hub

Showkey doesn’t show anything for the FN brightness - and + keys right now.

Maybe I found a clue, the issue only seems to happen when I cold boot. When the Framework is completely off, and I boot into the laptop the brightness keys don’t work. When I then issue a reboot (with the reboot command in my case), then the brightness keys do work.

That happens without changing any kernel parameters in between. Strange!

1 Like


1 Like