[SOLVED] Battery limits ignored when charged more than the limits

I have run into an issue with my framework i7-1185G7 / batch 8 / win11 - It seems that the battery limit set in the BIOS is ignored by the controller. No matter if I plug in the original AC adapter or my Thunderbolt dock. I have set it to 60% and I have confirmed that the settings have changed multiple times. It is at 60. Has someone ran into the same issue or can help me fix it? It’s a nearly fresh installation - the only thing I made was an upgrade to win11 at day 1.

What have you tried?

Try draining your battery first below your intended limit. Restart, set your limit at the BIOS then test.

In my experience, the limit is ignored when the battery charge is above the limit when the BIOS setting is changed.

Yeah. Tried to drain the battery - now the limit works as intended. Maybe there could be a feature patch of the firmware to poll the battery limit and charge and deactivate charging once it’s above the set level :thinking: That only has to be done when the battery limit is changed or an AC adapter is plugged in.

Ok can confirm

I thought I’d try and charge the battery fully

  • Disbaled max 90%
  • Set to 100%
  • Stoped at 98% as white light came on by unplugging
  • Reset max charge to 60%
  • Plugged in charger and the battery continued to charge

It seems that if the battery is already above the limit set the limit is ignored