[SOLVED] Bluetooth mouse lag (Linux, autosuspend)

  • Framework Laptop DIY Edition (12th Gen)
  • Linux Mint 21.1 (Vera)

I’ve a Logitech Pebble Bluetooth mouse connected to the internal Intel AX210 Bluetooth receiver. This basically works, but the mouse always “hangs” for 0.5s after 2s of inactivity.
After searching the internet and this forum, I found out, that this has something to do with USB autosuspend. I already have following udev rule created which disables autosuspend for the Intel AX210 Bluetooth receiver(/etc/udev/rules.d/99-usb_power_save.rules):

# blacklist for usb autosuspend
# Intel AX210 Bluetooth(embedded bluetooth receiver), solves mouse lag 
SUBSYSTEM=="usb", ATTR{idVendor}=="8087", ATTR{idProduct}=="0032", TEST=="power/control", ATTR{power/control}="on"

This rule works and solves the problem when run manually using sudo udevadm trigger.
My problem now is, that this is rule is not working on boot.
Any idea why this rule works manually but not on boot?

Not sure about using the udev rule, however, this may help as a boot parameter.


Thank you, that solved the mouse lag.

1 Like

Fantastic! marking solved.

1 Like

FWIW, I had a similar problem and this solution worked for me. linux - Bluetooth mouse sleeps after a few seconds idle when there is no other mouse connected - Unix & Linux Stack Exchange

Changing the boot options did not solve my problem.

1 Like

Thanks you :pray:

Adding the boot parameter resolved the same issue on my Thinkpad T14 Gen 3 AMD with Kernel 6.4.8-060408-generic on Linux Mint 21.2 Cinnamon.

1 Like

Delighted this worked out. :slight_smile: