[SOLVED] Drive not detecting on mac

I used one of the framework external 250 gig drives to boot ubuntu onto my framework. Now it wont detect on the mac that I originally used balena etcher to flash ubuntu from. Am I able to recover my drive now or did I f*ck it?

It will open when connected to my framework running ubuntu, it shows two icons, “writable” and “Ubuntu 22.04.1 LTS amd64”

that confuses me because if I still have the writable permission on this laptop then why the heck wont it detect on my mac anymore (i have connected it to another mac just to check, and yes, it doesn’t show up there either)

When you say it’s not “detected,” what exactly do you mean?

A flash drive containing Ubuntu may not show up in Finder since it doesn’t contain a filesystem that macOS can read. If it’s not showing up in Finder, that’s not unexpected.

If it’s not showing up in Disk Utility, however, that could be a problem. Disk Utility reports all of the storage devices attached to the system, and allows you to repartition them–Apple calls it “initializing”–and erase them.

1 Like

I just checked and it shows up as two drives, one 307 kb drive and the other as a 3.82 kb drive which doesn’t make sense as its only one drive and its also not of those values , it’s a framework 250 gb drive.

oh wait nvmd
it does show as 250 gb
what do I do from here?

If you’d like to erase all its contents, I’d recommend following Apple’s guide on it: Erase and reformat a storage device in Disk Utility on Mac - Apple Support

If not, you may need to explain what you’d like to do :sweat_smile:

Just pitching in here, that’s common with boot drives, they often are partitioned as such from experience!

Hopefully you manage to resolve the issue! Best of luck!

it shows up in disk utility but it always fails when I try to reformat to exFAT, the two little partitions are from the ubuntu download, i’m trying to gain access to the rest of the open space here, it just wont show up as a disk I can put files on


I fixed it finally, linux to the f*cking rescue baby! I was trying all this time to fix it in disk utility on mac but then I went into disks on my framework and it was a simple as deleting the partitions and then repartitioning and formatting into exFAT!

Thank you for the help though guys.