No Boot Media Detected

I am struggling to figure out how I can get my install of windows 10 installed on the framework device. I only have a MacBook laptop as my other device so i tried both the ISO and boot camp on the mac and it is not detecting the USB as having boot files. I tried a couple of the recommended settings in BIOS without much help, but I am not really seeing how to set a USB to be exactly what I need. Any help on what else to try would be appreciated.

Hi @Graigory_Logan how did you try to flash the USB with the ISO?
I would recommend that you use Etcher to flash the ISO into the USB.
If the USB is flashed correctly, then the framework laptop should boot into it (if you don’t have another running OS on the laptop). If it doesn’t boot into the flash drive, I would check the boot order on the BIOS.

Etcher failed to flash it gave errors right away and just said failed.

Have you tried other brand new USB drives. I have had a few fail out of the box. Etcher is very reliable.

Tried two different ones, taking a break now as I am just frustrated with how it is going.

See if you can get a friend who has a windows pc to load the USB drive. Hang in there… It’s a great machine (I’m B2)

Yeah looking at that now, as it doesn’t seem like its going to work from my mac for whatever reason. The assembly was the easy part, which I figured the install would have been.

Could it be the ISO that’s making the flash fail? How did you the the ISO?

I downloaded the ISO from the Microsoft page with the media tool, since i was on mac it redirected me to the ISO and then i used disk utility and boot camp to try to create a package that would work. I will have to see if I can get one of my friends to send me one with a windows created one unless i stumble across something else that works.

You could try getting an ISO from UUP dump it would include the newest updates. It takes a while to create the ISO though, but I use this at work all the time.

I will give it a shot! Thanks for the help!

I give up on trying to download from random websites. This has to be one of the worst times I have had trying to install something on a new device. I have built 4 computers in the past and the assembly went smoothly but installing the software seems impossible for me without already having a device or someone who is close I can get to build something. I can’t seem to accomplish this so I regret buying the license I like the computer but now I wonder if I should have just gone with something else.