[SOLVED] Fingerprint reader - Ubuntu Cinnamon

My issue is that I am trying to get my fingerprint reader to work and I cannot seem to figure it out.
I am setting up my Framework 13 Ryzen 7040 using Ubuntu - cinnamon 22.04. I was really hoping to using Linux Mint, but as official support is only for ubuntu, I thought I could probably compromise between the cinnamon user interface and ubuntu this way. It’s possible that my whole issue is simply to using the incorrect OS.

I’ve been attempting to follow the tutorial for Ubuntu fingerprint reader setup, but when I go to the Settings–>Users and Groups Menu, there is no option for fingerprint entry.

I then began trying to follow the tutorial here:

When I run the
fwupdmgr get-devices 1e8c8470-a49c-571a-82fd-19c9fa32b8c3
command, my system spits out info for my system firmware, my UEFI dbx, and my WD Black SSD, but does not recognize that a fingerprint reader is even connected.

Thank you in advance.

I’m also curious about this. I know that it’s likely an issue of the Cinnamon desktop environment not having a handy Fingerprint settings UI, but is there a good work-around?

I solved it!
I don’t remember the exact sequence I used, but I remember leaning heavily on this:

It was probably about a month ago that I figured it out, but I think, besides trying a number of other troubleshooting things on this website and others, the thinkpad walk-through is was ultimately sealed the deal.

I hope this will get you on the path to success.


Thanks for updating the thread @_Zeus , labeling as solved. :slight_smile: