[TRACKING] Can't get into computer - fingerprint reader

I cannot get into my laptop anymore. I am new at this and I guess that’s my first mistake.

I recently purchased a DIY framework. I followed the instructions and put it together, figured out how to make a bootable USB for Linux Mint Cinnamon and installed it, and everything has been working fine. I have been using it and have been really enjoying it. Until I restarted my computer, that is. Now, when I click the user icon to log in, it flashes to a screen that says the fingerprint reader couldn’t authenticate, and very quickly back to the username screen. It doesn’t stay there long enough for me to type a password. I’ve even tried rebooting it with the usb in again to see if I can just wipe the whole thing and reinstall linux. Nothing works. I try clicking the username with a mouse instead of the touchpad, using the keys instead of clicking, nothing works. Always the flashing to the screen saying the fingerprint didn’t work and then back again. I don’t know what to do. The machine is useless now and I’m very upset. Please help.

Was this solved adequately on Reddit?

Happy to help however I can.

There have been reports of LightDM on Linux Mint causing login loops when trying to use fingerprint readers.

Cinnamon (the desktop) is not “great” with the fingerprint reader. Ubuntu works far, far better for this sort of thing.

For fully supported fingerprint reader access, we recommend the Ubuntu or Fedora which have outstanding support.

If you do a reboot (F12), select the USB drive and then do a clean installation, it will knock everything out. In our testing, I found I had to do this multiple times because Cinnamon wasn’t playing nice.

Because of this, I’ve actually removed the problematic section for using the fingerprint reader in the Linux Mint guide as unlike Ubuntu and Fedora, it’s simply not recommended.

Can you walk me through the process you took in trying to do a fresh installation? Perhaps it was skipping the flash drive and going straight to the internal drive?

I hate to be the bearer of bad news but I believe this is a known bug with fprintd starting back in 20.04 and probably all the derivatives. I recently invoked this bug while trying to get the fingerprint reader to work beyond GDM for logging in (like sudo prompts in terminal or on the GUI).

FYI: These steps are geared towards Ubuntu 22.04.1 LTS but they should translate over to Mint

First I would remove fprintd completely to get yourself logged back in. Here is how I did it:
Wait for the login screen to appear then switch to a different TTY
CTRL + ALT + F2 (is what I used) should show you a terminal login (no-GUI)
Get logged in and remove the fprintd package
sudo apt remove --purge fprintd
cleanup anything left over
sudo apt autoremove --purge

Now you can stop here and just switch back to (most likely CTRL+ALT+F1) and try to login (maybe reboot first idk). If you continue with the below steps, it MIGHT fix your fingerprint reader issues.

sudo apt install libpam-fprintd
this should automatically hit the fprintd meta package and install any dependencies.
Next make sure it’s started
sudo systemctl status fprintd.service
if it ain’t green (active) then restart it
sudo systemctl restart fprintd.service

Enroll your fingerprint:

after it shows completed run the following (DO NOT TEST IT OUT YET, PATIENCE!)
sudo pam-auth-update
select Fingerprint Authentication and Ok
Reboot your machine
Try and login with your fingerprint
Try “sudo” from terminal and see if it prompts/accepts your fingerprint
Try launching a GUI app that requires sudo and see if it works

Your mileage my vary, this is just how I went about fixing mine. I would stay out of the GUI in Users settings.

So we have the steps provided in this section of the user guide for Ubuntu 22.04.

On the left side, under Sudo with your fingerprints. You can also add your ability to login from Users in settings once this is done as well.