[SOLVED] Gen 13 + 990 PRO + Win 11 Installation issue

Hi community!
I am excited to become part of the Framework community with my first Framework laptop.

I received the 13 inch 13 gen 1370p a couple of days ago, and I ordered without the SSD - I bought a 990 PRO separately. I assembled the laptop, and attempted to install Win 11 using a USB 3.2 bootable drive. I ran into issues when I attempted to create a partition - I was getting a cryptic “Failed to create a partition” error message inside of the Windows installer.

To resolve it, I tried going through the repair my PC option of the installer instead, entering CMD and then tried to create a partition using DISKPART tool. I was getting an access denied message, so I tried to clear the read-only attribute, but that didn’t resolve anything.

In an attempt to solve this I created another bootable drive (exactly the same USB 3.2 stick, just a second one I had) with Win 11 and repeated the procedure, but it didn’t help.

I then cleared one of the drives and made it a bootable installer for Windows 10 instead, and then repeated the procedure using DISKPART which succeeded in creating a partition. However, I ran into a problem when I tried to use Win 11 drive to install windows on the newly created partition because the drive was set up to use MBR instead of GPT records, so I had to redo everything, but with a switch to GPT added in the middle.

I am adding the commands I used in DISKPART here in hopes that if someone runs into the same problem they have the solution in one place, but I would love to hear from everybody who knows more on why this would happen - hoping to learn something new :slight_smile:


  1. Create a bootable Win 10 Installer USB drive
  2. Boot from the said USB drive and instead of pressing “Install now” choose “Repair” option on the bottom left of the window
  3. Enter Command prompt and type these commands:
start diskpart

This will show another CMD prompt with DISKPART tool, switch to that one and keep going:

list disk

This will give you a small table showing the SSD (probably as number 0) and the bootable USB drive. For me the SSD was 0 and the rest of the commands will assume the same is true for you, but you might need to edit them for your use case.

select disk 0
convert gpt
create partition primary -size=307200

Size is number of MB, in my case I chose 300GB for the primary partition. If you don’t want to use multiple partitions you can omit the size parameter and the partition will automatically use up the whole available space.
4. Exit the tool and turn off the PC.
5. Create a Windows 11 Installer USB drive and boot to it.
5. Choose “Install now” option and proceed as the wizard leads you. When you arrive at the partition choosing step, select the partition you created in step 3, format it, and continue through the installer. Hopefully this solved your problem and you successfully installed Windows 11. If not feel free to respond to this thread for further help.


Interesting, I have a Gen 13 on order and will also be using a 990 Pro and Windows 11 Pro. I will reply here if I experience a similar situation to you.

Just curious if you had any other memory module connected during the Win 11 install? Such as one of the 250GB or 1TB modules Framework sells?

Also, did you try the trick to unplug your USB installer drive at the time W11 wanted to create the partition to see if that helps work around the problem? Some have done this and successfully formatted the partition. Once the partition formats you’d then reconnect the USB installer drive.

Hi Scott!

I did not have any additional storage expansion slots plugged in, and when I first encountered the issue, I even unplugged all expansion cards but the USB-A one.

I did not try unplugging the USB drive before creating or formatting the partition, it didn’t occur to me, nor did I read anybody recommending that. I hope I remember to try this the next time :slight_smile:

Good luck and post back your experience!

1 Like

I did some additional research on this. If you don’t already have Samsung Magician software installed, I suggest doing so as Samsung has already released a couple of firmware upgrades for the 990 Pro. The first upgrade released in February 2023 addressed drive health issues (premature wear). A second upgrade was released in May 2023 to address drive locking.

In your case hopefully your 990 Pro has the 1B upgrade already installed from the factory.

The 3B upgrade is newer and likely your drive doesn’t have that fix. I wonder if this “drive locking issue” they fixed is responsible for your partitioning and format failures during install?

The 990 Pro I received was produced in May 2023 so I know it has 1B but probably not 3B. I’ll run the ISO boot upgrader prior to installing W11.

You can read more about this at the below url


1 Like

Thank you for the info. I checked and my 990 was indeed on 1B. I upgraded the firmware now, but obviously am not going to try and re-partition the PC to test it out. I hope this solves any potential problems for you and others :slight_smile:

1 Like

To follow up on this matter. I got my laptop running. My 990 Pro had firmware 3B on it from the factory. I had no issues installing Windows 11 Pro from media created using the Media Creation Tool. Of course I did make sure the wifi card was set to Fallback until after the current drivers were installed. So far very happy with the 990 Pro

hey @Scott_H … I’m trying to do a fresh Win 11 install on a 990 Pro. Do I need to put the drive in some other system to update the firmware before the drive will be recognized by the Win 11 installer? I read somewhere else that the problem is the Windows 11 default NVMe driver doesn’t support the 990 Pro, but Samsung doesn’t have a .zip file anywhere of the driver… they only make Magician or some other .exe file that requires Windows to be installed first.

I used the Media Creation Tool to build W11 installation media. I have a 13th Gen Intel system and had no problems with the BIOS and W11 detecting the 990Pro. No need to install additional drivers, however if you do you’d likely need the Intel RST floppy driver.

Thanks @Scott_H … I used belenaEtcher to make my win11 installer and that was the problem. I switched to Microsoft’s media creation tool and it worked great.