[RESOLVED] SSD not recognized by windows 11 installer

This is my configuration:

  • Framework 13", Ryzen 7640U
  • 1x16Gb Ram (bought from framework)
  • 1Tb SSD (taken from my X1 Carbon Gen7)
  • BIOS Version: 3.03

I initially installed Gentoo on my system (and left some room to install Windows 11 at a later date) with the following partition schema in order (using a GPT partition schema):

  1. 1Gb FAT32 (for uefi)
  2. 700Gb EXT4 partition (for my gentoo’s root installation)
  3. 253 Gb blank NTFS partition (for my future windows 11 install)

I formatted the partition in linux using mkfs.ntfs. When I boot into my windows 11 bootable drive though, the installer doesn’t see any drive. I get an error complaining about missing drivers. The weird part though is that when entering the console with shift+f10, I can see my disk and it’s partitions with diskpart.

Here is what I tried to fix the issue:

  • Install the driver bundle from framework (sadly, it’s an .exe which I can’t run from within the installer, only after first boot)
  • Use set id=... for both my primary windows partition and the uefi on within diskpart (I had to rerun grub-mkconfig afterwards)
  • Try another windows 11 installer (I tried using Tiny11 from NTDEV)

Whatever I try, I can’t see my partition ( or disk for that matter) to show up so I can select it to install Windows 11 on it.

I do not want to erase Gentoo (compiling it took way to long to do that twice, lol).
Is there something I’m missing here?

I have seen reports on the community Discord of users encountering this issue when they use Ventoy to boot the Windows install media.

Are you using Ventoy?

Nope, i just flashed the iso using the dd command

Huh, that’s not a method I expected to work.

Just to rule it out… if you have a Windows machine handy can you use the Windows Media Creation Tool or Rufus?

If you don’t have Windows, you can format a USB drive with a single FAT32 partition and copy the contents of the ISO to it.

If sources/install.wim is too large for FAT32, you can split it with wimtoolswimsplit tool:

wimsplit install.wim install.swm 4000

… and then place install*.swm into sources/ on the USB drive.


Quick update, the culprit of my issue seems to have been the way I created my Windows installer bootable drive. dd is a great command for creating linux bootable drives but not so much for windows. I did not have any Windows computer handy to create my drive (using rufus or other). This is how my issue got fixed: I installed my windows iso to my thumb drive using a tool called woeUSB. It seems some key drivers used to read drives in the installer were incorrectly copied with my previous method (hence why some methods such as diskpart worked but others did not).