[SOLVED] If no response from tech support, this is a $2,000 boat anchor

If no response from tech support, this is a $2,000 boat anchor.
AMD and can’t connect to wifi.
Every instruction I have found requires a bypass or no start of the setup and I have spent hours trying to do that.
70 years old and very frustrated.
If I could figure out how to do it, I would wipe the drive and start over but see no option in the bios to do that.

Are you on Windows 11? Wifi doesn’t work out of the box with the DIY version as the Windows installer currently doesn’t have the appropriate drivers for it. If you’ve already gotten into Windows, you can download the driver bundle on another computer from here (link: Framework Laptop BIOS and Driver Releases (AMD Ryzen™ 7040 Series)), load it onto a USB and run it on the Framework laptop, it’ll install the wifi driver and you will have wifi. If you follow the installation guide here for windws (link: Windows 11 Installation on the Framework Laptop 13 (AMD Ryzen™ 7040 Series) - Framework Guides), it’ll allow you to bypass the wifi requirements when installing windows then you can proceed with running the driver bundle.


Hey Alan,

Thank you for creating this thread.

I see that you have contacted our support team three hours ago, they usually reply back within 1 business day, we appreciate your patience.

Meanwhile, please share any issues you are facing here so that other community members can help you solve them. The suggestion TheTRUEAsian shared above will most likely solve your issue, your wifi issue should be resolved after you download and install the Driver Bundle.

Please let us know if you have any issues with that and we can try to help you!


As near as I can tell I have enough of the installation on the drive that it automatically goes there. The Framework bios seems to have no way for me to select boot from usb first and no way to wipe the drive to start over.
I can go to bios (no help) or install (no wifi), but nothing else.

It really frustrates me that because I received this thing on a Friday, it will take me longer to get it to work (if tech support is needed), than the time it took to order and receive it (2 days).

In the mean time, ensure you followed Framework’s official guide for creating your installation media for Windows 11. The symptoms you’re describing sound like that’s the issue. The detailed guide can be found here: Windows 11 Installation on the Framework Laptop 13 (AMD Ryzen™ 7040 Series) - Framework Guides

You can access the boot media selection screen (where you can select the USB drive) by repeatedly pressing F12 while the computer is booting, as documented here: Windows 11 Installation on the Framework Laptop DIY Edition - Framework Guides


I think you are right, but have no idea how to fix it.
Aren’t old people fun?..LOL

The guides I linked should give you all the information you need. DIY edition is intended for more technical users, so you may want to consider returning your DIY edition under the 30-day return policy and purchasing a pre-built Framework Laptop, which will have Windows pre-installed.

F12 is also not working, because no drives are listed.

That’s certainly odd behavior. Not even your internal SSD appears in the boot menu? If you don’t press F12, does it boot to Windows?

I actually have a BSU computer repair degree (1996) and am a retired database administrator (last done in 2000) but now am a lot older and things seem to have changed a lot.

Maybe if you could share what you see in the Boot menu (if the internal SSD appears there or not) and what happens if you don’t press F12 (does it boot to Windows?) we can help you further!

1 Like

You can mash F2 during startup from a shutdown which will allow you to enter the BIOS. From there, you can enable “Boot from USB” which should allow you to boot from a USB. Furthermore, you can select boot priority in another menu.

1 Like

It boots to the install, first language, then keyboard, then second keyboard, then wi-fi where I am stuck.

Under boot from usb I get options for items being attached and no matter what I select it goes straight to the ssd.

I am currently re-doing my boot thumb drive but am pretty sure that will not help me.
I need to reformat the ssd, but find no way to do that.

In the boot options, there should be a way to disable the SSD as an option. As for formatting the drive, in the Windows installer, there is an option to delete the partitions off an existing drive.

In boot options, do you mean in the bios? I am seeing nothing like that, but then this framework bios is completely foreign to me.
Like I said before- “It boots to the install- first language, then keyboard, then second keyboard, then wi-fi where I am stuck.” Nothing else.

At this point, the easiest thing to do is at the wifi section, press Shift + F10 (or Function + Shift + F10). You will see a command prompt window open. Then type “oobe\BypassNRO” and hit enter. The laptop will then restart and after entering the network page, it’ll then allow you to proceed without connecting to the internet. After setup is complete, run the driver bundle and you’ll have wifi.


Someone told me that earlier and it did nothing.
Tried it again now, still nothing.