[SOLVED] Just got my FW16 (Batch#18) up and running!

I am elated with the [Framework Laptop 16]

Putting it together was a breeze due to the online instructions that left all questions to the ether and above all else it was fun! This was the first DIY that I have purchased and the others have been pre-built.

Moving forward I would consider pre-built and not take the time to DIY.

In my current case, I installed everything easily, the operating system needs the window drive patch; that went well as you can imagine. It was not an issue at all and went smoothly. Installing the ram was straight forward.

The storage went well, booted and was usable through the BIOS read and usable once during OS setup.

  • Storage: WD_BLACK™ SN770 NVMe™- M.2 2280 - 500GB
  • Storage: Western Digital SN740 NVMe™ - M.2 2230 - 2TB

I opted to us the 500GB as my windows OS and 2TB was split from dev 500GB, 500GB for operating storage and 1TB for backup using “old school” rsync and to get pulled by the storage servers. The 2 days of backup are planned on the 1TB backup and then rotated,

Every backup gets pulled off and stored and that goes into storage for 90 days then rotates. worked well, so I got a a lot keyboard time on this FWLT16 t date. Its so fast I need a fire retardant suit so I don’t get burned sitting so close. :wink: LOL

So once this was all setup I rebooted the system and now I can only see the C: 500GB and the 2TB is not available nor visible. I have not checked the BIOS to see if its recognized nor have I tried to reset the storage on the board. I thought I would ask here first and see if the deep talent rich environment would offer some words of advice a quick smack to the head to get me moving forward.

I am sure it was something I did and thinking back forcing the 500 GB to the C: drive. may have been the issue. I set the 1TB to the D: drive (this is split by directories only) and 1TB to the Z: drive

Any advice?



  • Framework Laptop 16 (Batch18)
  • Operating System: Windows 11 Pro
    Ryzen™ 9 7940HS
  • System: Ryzen™ 9 7940HS
  • Memory: DDR5-5600 - 64GB (2 x 32GB)
  • Storage: WD_BLACK™ SN770 NVMe™- M.2 2280 - 500GB
  • Storage: Western Digital SN740 NVMe™ - M.2 2230 - 2TB

Hi @Joseph_Savard,

Congrats on your new machine. They are incredibly quick! There is a known issue with the factory BIOS where the 2230 drives disappear after rebooting. I suggest:

Updating to the newest BIOS (I believe it is v3.03?)
After updating, go into the BIOS and use the “Set BIOS Defaults” (F9 I think is the hotkey)
Then reboot the machine again.

This should fix the 2230 drive disappearing, at least the first known reason why it was disappearing.

1 Like

That is absolutely what I was looking for!! I have not done the bios update but here we go! Thank you! report back soon.

Thank you!

Prior to updating the BIOS I rebooted and my D: drive and Z: drive reappeared and my backup script functioned properly.

So, I still opted to upgrade the BIOS 03.02 to 03.03.

BIOS Version/Date INSYDE Corp. 03.02, 1/23/2024
BIOS Version/Date INSYDE Corp. 03.03, 3/27/2024

Name Used (GB) Free (GB)

C 79.70 385.19 C:\
D 7.43 450 FileSystem D:
S 13.98 450 FileSystem S:
Z 0.14 1000.11 FileSystem Z:\

All drives available and BIOS upgrade went smoothly!

1 Like