[SOLVED] No Euro sign on German Keyboard

As it says in the title, I am unable to produce the Euro sign on my German keyboard layout.

  • I have the Symbol where it is supposed to be on the physical keyboard
  • Pressing the usual combination alt gr + e does nothing
  • alt gr works for other combinations, such as alt gr + q = @ and alt gr + 7/8 = {/}
  • my system language(Windows display language) is english (as it is on my PC and surface too)
  • Country/Region is set to Germany
  • Regional format is set to English(Germany)

I am otherwise extremely happy with my framework but this annoys me more and more each time I have to google “euro sign” to then copy and paste it.

Please let me know if I am missing something (obvious) or explain to me how to fix this issue. Thanks in advance! :blush:

Do you have qwertz or qwerty layout set in Windows?

The layout is qwertz.

Just a workaround but you could try to use a tool like Autohotkey or ac’tivaid from heise/c’t to create a custom mapping.
Doesn’t solve the issue but might help you in case there is no other fix. However, I’m curious if someone can reproduce it.

1 Like

Hey guys, I found my culprit. Windows PowerToys, or more specifically Mouse without Borders had one of its Presets set to Ctrl+Alt+E which ist alt gr + e and therefore overwrote the Euro sign combination.

As for me this can be marked as “solved” or otherwise closed. Thanks!


Great that you found the culprit.
I added [SOLVED] to the thread title.

I believe most users have the option to edit their own thread titles, but there might be restrictions for very new users, I presume for the purposes of spam prevention from bots.
If you have the option then a pencil icon shows next to the title which you can click.

Clicking the pencil will bring up these edit options.

1 Like