[SOLVED] No internet access when connected to iOS wifi hotspot (Fedora 38)

Since a couple of months ago, I can’t access the internet on my 12th gen Framework laptop via my iPhone’s mobile wifi hotspot. I’m using Fedora Workstation 38. I’ve tried this in 3 different locations where my iPhone had good reception but my laptop still can’t access the internet through it.

I get the following error message when trying to open a page in Firefox:

Note that the wifi indicator in the top-right corner of the screen has a question mark over it.

I’ve tried plugging my iPhone in via USB and using it as a wired hotspot but the result was the same.

I haven’t changed any settings on my iPhone since I could last connect to the internet via this hotspot. I can connect to my home wifi network and to public wifi networks just fine.

Forgetting the hotspot wifi network and reconnecting didn’t help. Nor did enabling the hotspot setting on the iPhone called “Maximise compatibility”.

Is there anything else I can try? Has anyone else encountered this problem?

Thank you

That seems to indicate no DNS resolution.

Try basic networking from a shell (command prompt):

ping -c 10

which will ping (Google DNS, should be anywhere in the world) with 10 pings. You should get something like:

$ ping -c 10
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=117 time=12.7 ms
64 bytes from icmp_seq=2 ttl=117 time=11.6 ms
64 bytes from icmp_seq=3 ttl=117 time=12.0 ms
64 bytes from icmp_seq=4 ttl=117 time=11.2 ms
64 bytes from icmp_seq=5 ttl=117 time=13.1 ms
64 bytes from icmp_seq=6 ttl=117 time=13.4 ms
64 bytes from icmp_seq=7 ttl=117 time=11.6 ms
64 bytes from icmp_seq=8 ttl=117 time=14.0 ms
64 bytes from icmp_seq=9 ttl=117 time=13.4 ms
64 bytes from icmp_seq=10 ttl=117 time=11.2 ms

--- ping statistics ---
10 packets transmitted, 10 received, 0% packet loss, time 9013ms
rtt min/avg/max/mdev = 11.210/12.413/13.955/0.955 ms

That will indicate your network is working, but you can’t get DNS resolution. With that, you could actually load a site by its IP address, but that’s a little…inconvenient.

If this doesn’t work, basic networking is not working at all.

My guess is this will work, but where to go from here - umm. Check your network settings, make sure DNS is set to automatic. Or you could put here.


My wild guess is that perhaps OP set up a Pihole two months ago. Been there, done that. :laughing:

1 Like

The problem was as you described. I could ping successfully.

The IPv4 and IPv6 settings both had DNS set to Automatic.

I changed the IPv4 DNS to and now I can access the internet again via my hotspot!

Thank you so much for your help, that’s made it so much easier to work while travelling. Much appreciated!

Oh dear, sounds difficult to pin down! No Pihole here, never touched one. Not really sure what it is! Installed a VPN browser extension once but that’s as far as I went.



Not sure why it wouldn’t use the DNS provided to it by the hotspot, but I think sometimes hotspots don’t respond to DNS requests in a timely manner and the client gives up prematurely.

Google “public DNS servers”, you’ll see lots. Google also has, there’s, Quad9 ( and lots more. If Google works for you, great. But there are other options.

1 Like

labeling this as solved. thanks @Fraoch

1 Like