[SOLVED] Root console / EFI shell : how can I configure network?


Long story (skip if you want) :

My background : I have been a mac user for decades, but I allerady installed and used Debian on an old laptop.

When I received my 12th gen Framework Laptop, I installed Linux Mint 21.1 Cinnamon to test it.

Later on, I formated an external SSD with ZFS (I wanted an encrypted drive that could be read by Linux and Mac OS X. ZFS was one of the best solutions).
Learning things about ZFS, I wanted to give it a try as a root filesystem on my Framework Laptop.

I read that Debian Bookworm worked quite well on the Framework Laptops.
So I decided to try a multi-boot ZFS with Debian and Linux Mint.

First step was to install ZFSBootMenu with Bookworm.
So I began the Bullseye UEFI manual (the manual for Bookworm does not exist yet), trying to adapt things for Bookworm.

The first thing to do is to “boot your system in EFI mode”.
So in Grub 2.06, I picked “Advanced options for Linux Mint 21.1 Cinnamon”
Then “Linux Mint 21.1 Cinnamon, with Linux 5.15.0-60-generic (recovery mode)”
Then “Passer sur une console administrateur (root)”, which could translate to “Switch to root console”.

I am not sure this root console is a boot in EFI mode.

Following the same manual the “apt update” instruction failed of course : there is no network.
I tried to configure the wifi card with iwconfig, and a USB ethernet “dock” with ifconfig, but I failed.
A strange thing is that ifconfig with either “dhcp” or “static” options failed : “dhcp: unknown host” and “static: unknown host”.
I could successfully ping machines on my LAN (but nothing on the WAN) after I configured my ethernet with
sudo ifconfig -s enx00
(yes I had to omit “static”).

Long story short :

  • what is the best way to boot in EFI mode ?
  • how can I have a network connection (through wifi prefered ; or through my USB to ethernet bridge) ?

Thanks for your help !


The Framework Laptop does not support Legacy boot, so you don’t need to worry about this. It always boots in EFI mode.

True, @DHowett but if you have a look at the link in the first message, you will see that the install process begins with command lines.
It was my understanding that you must enter kind of an EFI shell (that they called EFI mode), and was not sure to do the right thing, entering the root console.

Do you think that I can just open a terminal to do all this voodoo ?

By the way, thank you !


Wrong gateway (if you care about what went wrong…even though you didn’t ask for this).

sudo / apt / ifconfig are all linux commands. You’re in a some linux shell, not an EFI shell. I don’t see wording of “EFI shell” in your link in the first message (am I searching incorrectly?). Stick to the wording used in the link / document (Coming up with terminology base on your interpretation in a troubleshooting / Q&A scenario can be confusing for everyone).

Thank you @Second_Coming for your answer !

You are right ! I did a bad copy, mixing two lines.
The line that gave access to the LAN but not the WAN was :

sudo ifconfig -s enx00

Given that I had no access to the WAN, I later tried to add a DNS :

sudo ifconfig -s enx00

But the result was that I lost the LAN (and had no WAN, of course).

I just edited the first post to correct the history of what I did. Thanks !

Yes, I asked for this :

  • The title includes “How can I configure network?”
  • The “Long story short” part asks “how can I have a network connection”

Thank you for replying !

This is right !
I used the wording “Root console / EFI shell” in the title, to show that I am confused about what the manual asks for.

I will try to do the command line voodoo in a terminal. It should help with network access, as Debian will take care of it.

Have a nice day !