[SOLVED] Tails wont work on Framework Laptop

I can’t boot into tails from a usb on the framework laptop.

I feel like I have tried everything, but cant seem to get it to work. I have made multiple tails usbs that all boot on my other laptops.

It is also not a discovery problem, I can find the usb, and choose to boot into tails on it. Then tails will not load.

It did load, and functioned properly like the second or third time time I tried, but since then no luck. I have tried like 50 more times while troubleshooting, but nothing since.

Its driving me crazy because I know its possible being that it did work that one time…

is anyone else able to run Tails?

or has anyone run into similar issues and found any answers?

I don’t know tails, but it sound familiar to my experience of installing popOS 22.04 on the Framework Laptop…

Go to BIOS and disable secure boot then retry to boot from the USB key

That did the trick for me

Still getting a “unable to find a medium containing a live file system” error

I tested Tails v5.4 and was able to load it without issues, the wifi adapted is not recognised but otherwise all seems to work as expected.

I also seem unable to get Tails to boot. Tried 3 different types of USB drive, 2 of which work on other machines, yet they don’t work on the Framework. I either get the “unable to find a medium containing a live file system” error, or it freezes when the three dots appear during boot. I’ve disabled Secure Boot but nothing has changed. I’ll see if I can find other USB drives to use and can report back if something works.

4th time lucky! It seems to depend on the USB drive being used. I’ve now switched to a Toshiba 8GB drive and booted into it a few times without issue. Previously, I was trying with 2 types of Kingston drives (one of which Tails themselves say has issues) and some unbranded one.

1 Like

Interesting… Thats so weird, i have tried multiple different usbs, they all work on my other laptops. Seems like we are having the exact same problem. i will try a couple other usbs and see if they work.

There is no compatibility issues with the drives on the framework except that they wont boot, works perfectly for all other purposes. (i even tried with the framework expansion card and no luck booting)

Im aware the wifi card is not yet supported, but i have an external one that works. Only if i could boot into tails to use it lmao

do you mind telling me the exact usb you using?

what usb exactly are you using?

It is a 16 gb USB 2.0 “Sandisk Ultra”

result of lsusb -v

idVendor 0x0781 SanDisk Corp.
idProduct 0x556c Ultra
bcdDevice 1.26
iManufacturer 1 SanDisk
iProduct 2 Firebird USB Flash Drive`

Toshiba TransMemory 8GB


SOLVED: (must use usb 2.0 flash drive)

Seems to be an issue with usb 3.0 flash drives.

I ordered a bunch of different usb flash drives to do some boot testing and usba 3.0 and usbc drives seem to be the problem.

All usba 2.0 flash drives that I have tested are booting into tails.


Glad you sorted it out!

Tried USB 2.0 and SD card as it was the only suitable medium for me, never would have thought USB 3.0 could be a problem for bootable USB stick.

I have done loads of USB 3.0 windows installation media, never had an issue…

Tails 5.5 (released last week) uses kernel 5.10.140.

According to this Debian bug issue AX210 wi-fi card only works on kernel 5.14 onwards.

For any other you need to install firmware-iwlwifi.

I’m having this same issue, but don’t own any USB 2 flashdrives or hubs.

It would be really nice if we could get to the bottom of this, because my USB 3 tails drive works fine on all my other computers.

I also tried removing “live-media=removable” from the grub options in case the laptop was somehow treating it as non-removable, but no luck.

I still havent come to a solution, it just wont read non-usb 2 drives as a live OS for some reason.

I have been using these drives from amazon and can confirm they work with no issue…


I can confirm that tails 5.10 works from a usb 3.0 in a framework laptop 12th gen