[SOLVED] Ubuntu 22.10+ (kernel 5.15+) external HD screen over HDMI unstable with FW 12th gen

Hello all o/

Ever since I built my Framework DIY (which I love, BTW), I’m having troubles with external screens over the HDMI adapter.

On kernel 5.15, the external screen will blank / turn off and on every so often (multiple times in an hour), there’s no dmesg messages or anything else that would suggest what’s happening. On 5.19 it’s worse, unusable. The external display will blank multiple times a minute.

Tried multiple HDMI cables with same result. I’ve yet to try another USB-C adapter, or a DisplayPort connection.

I’ve filed an Ubuntu bug but there’s little movement on it unfortunately:

I’ve not found anything similar on the forums, but maybe I’m missing something?

Thanks all.

Appreciate the hard work here, thanks for being clear and providing a ton of helpful details.

So these are not HDMI expansion cards or DP expansion cards? If not, let me know. While our options will be limited at that point, there are some tricks we can do with boot parameters to “force” the displays to remain on and working.

Sorry, I completely blanked on the “expansion card” term when writing that. And then… I didn’t get notified about your reply :frowning:

It is with the HDMI expansion card indeed. Let me know please what I can try and I’ll try and fix my notification settings in the mean time.

Okay, thanks for clarifying.

You’re not using the 5.19 kernel on 22.10, is that correct? This would be my recommendation first.

Next thing we can try is more designed for a second display that doesn’t turn on at all, so I’d prefer to simply use start testing with a 5.19 kernel or at the very least the 5.17 kernel.

Anything beyond 5.15 (I’m currently on 5.15.0-35-generic) just makes the external display unusable - it will blink on/off multiple times a minute. With 5.15 it only a handful of times an hour - unpleasant, but workable.

I have 5.19 (5.19.0-32-generic and 5.19.0-35-generic) installed, just not used - I can easily switch over.

This is beginning to sound like a bad expansion card. Just to confirm its not something else, please verify this happened in other expansion slots. If the HDMI card did this in multiple slots, please reach out to support for a replacement HDMI card linking to this post.

I had that exact problem for about the first 3 months with my DIY (gen 12 1260P) laptop. I tried various kernels from the 5.15 to the 6.0 kernel (I am using Ubuntu 22.04) with no luck. I tried a different TV display, same result. Tried switching the hdmi expansion card to different ports, no change.

I was at the point of contacting support thinking it may be a faulty HDMI card but luckily I changed out the HDMI cable I was using and haven’t had an issue since (for about 2 months now). The cables I were using were thin cables, I use them with raspberry pi units fine but were causing this very problem you mention when used with the framework laptop.

A much thicker HDMI cable, I assume it is better shielded, is now in use and in the last 2 months have not had one drop out. My laptop is used nearly all the time connected to a 1920x1080 TV (I have 2 such displays). This issue was a real annoyance for the first ~3 months of use. In my case the issue was the quality of the HDMI cable in use, the thicker, likely better shielded, cable fixed the issue for me.

Good luck, hope you find a fix that works for you as this is a really annoying issue to encounter.

Edit: I should note the thin cables were 6 ft (1.8m) long vs. 5 ft 4 in (1.6m) for the thicker cable that fixed my issues. See next image…

1 Like

Yes it is happening in all the expansion ports. I’ll try an external HDMI adapter as well, before contacting support. Thanks!

As mentioned in my OP, I tried different HDMI cables - a HDMI 2.1, in fact (driving just a 1920x1200 screen, so well under the capabilities of the cable).

Sorry, I must have missed that bit about the cable when reading your post. In that case I’d suspect @Matt_Hartley is right and it does sound like it might be a faulty hdmi expansion card. As I noted above, before fixing mine with a cable swap out, I was on the verge of contacting support with the same idea about a faulty card.
Regards, yeti.

1 Like

And yes, a simple USB-C to HDMI adapter works just fine. Thanks for the help, I’d never have claimed it to be a hardware issue since the kernel version changed the behaviour so much…

Sounds like you are using a USB-C expansion card that now has a HDMI adapter plugged in, is this correct? If so, this does like a bad HDMI expansion card and you will want to contact support about the bad HDMI expansion card.

Correct, I’ve already contacted support. Thank you!

1 Like

Finally got my new expansion card. And it works!

I would never have thought it’s a hardware issue when the kernel version changed the symptoms so much!

Thanks again all.


I’m also having this issue on Ubuntu 23. Though, it’s not as much of a problem in normal use (once/minute), it just gets really bad (once/3sec) when running xemu (og Xbox emulator)

It gets especially bad in 4k 60hz, not quite as bad with 2k 120hz

Ultimately the thing that really helped here was a USB-C hub. The new HDMI expansion card was better, but not problem free.