[SOLVED] USB 3.0 key disconnect and reconnect on W11

I am having issue with USB 3.0 device on my FW laptop

USB key keep on disconnecting/reconnecting on W11, but seems to work OK on popOS 22.04

Framework suggest this when trying to contact support :


I am already on BIOS 3.10

Has anyone tried this on W11?

Asking because on the 4th point I don’t have USB settings under modifying power plan and only the powershell command doesn’t seem to be enough :thinking:

So after multiple exchange with support and different tests, cumulative update 2022-10 for windows 11 appear to have corrected my problem.

:+1: to the support team for the patience and advice

1 Like

Is the issue addressed by the “cumulative update 2022-10 for windows 11” alone, or in combination with other configuration changes (e.g. the Kustomer link in the OP)? I assume it’s the “cumulative update 2022-10 for windows 11 version 22H2”, correct?

Also, what was the model of the USB 3.0 key / device in question?


yes 22H2.

As stated in first post :

The kustomer link wasn’t solving anything prior to the 2022-10 22H2 update of W11, so I assumed the windows update was what solved it…

Kingston Datatraveler G4 32 Go.

And the USB key was working perfectly on same laptop with fedora 36.

Here is what I’ve done with support :

  • Check BIOS version : was already running 3.10
  • Confirm that the key wasn’t working properly on all expansion bays, with and without AC plugged in
  • Confirm the USB key was working with my fedora install on 250 Go expansion card
  • Reinstall driver bundle for Windows 11
  • Install Intel Driver & Support Assistant : found update driver for Bluetooth and wireless
  • Install all update (before 2022-10 22H2 was out) : was still not working
  • Install 2022-10 22H2 W11, seems to be working now :crossed_fingers:

One additional note : I’ve made a English session to be sure, on W11 there’s no USB setting where Kustomer link ask you to change a settings… Maybe it is a change between W10 and W11…

P.S : @Fraoch the page for the kustomer is broken in french (/fr/ instead of /en/) on point 3) and 4). Should be a quick fix :wink:

1 Like

Strange, I’m not able to find any mention of USB-related fixes from Microsoft: