Bluetooth devices un-pair & won't reconnect in windows

I am having major issues keeping bluetooth devices connected in windows. I had no issues when I was running Fedora, but I need to run a few windows only apps so I switched. I’ve tried both windows 10 and 11 and have the same issues. All drivers are installed, all updates are current. Here’s the issue: I pair a keyboard and mouse. Whenever they disconnect (either by restarting the pc or when they go into powersave mode) they will not reconnect. The only way to reconnect is to re-pair them. I’ve tried unchecking “allow the computer to turn off this device to save power” in device manager, I’ve tried updating drivers, both versions of windows, etc. I know it is not the devices, they worked perfectly fine in Linux. The devices I am using are:

Microsoft - Full-size Wireless Bluetooth Mechanical Keyboard and Mouse Bundle - Glacier
Microsoft - Full-size Wireless Number Pad - Glacier

**I’ve also installed Microsoft Mouse and Keyboard Center. Still no help.
12th gen i5 32GB ram

Morning Mike, did you manage to get to the bottom of this?

Same issue here with a razer pro click mini.
Worked perfectly on Linux Mint, Fedora and Windows 11.

Haven’t had the issue before the Mai 2023 iirc.
Tried with the razer support but to no avail, they didn’t stop asking for information they already had.

Now Fedora doesn’t see it and it doesn’t reconnect to windows.

If any one here have a solution or a troubleshooting method, it would be a god sent.