[SOLVED] Wifi issues on new Framework laptop with old wifi card


I received my laptop this past Sunday to great excitement. My last computer was an Acer Predator Triton 500, which was a pain and a half to try to switch the ram, wifi, and storage out of- which is exactly what I had to do when it suddenly stopped recognizing the SSD

The pieces I got from Framework are:
CPU: i7-1165G7
(plus power supply and misc. expansion cards)

I brought with me though my wifi card from my previous laptop:
Killer 1550i
Intel model 9560NGW

also a Western Digital terabyte SSD.

EndeavourOS (based on Archlinux)

So the issue. The issue is wifi does not work. On the previous laptop, wifi worked from the live image of Endeavour. It is not working now from live or installed on the Framework.

What I’ve tried:
-searching for the driver (Intel website says the linux driver for the Killer 1550i is equivalent to that of the Intel® Wireless-AC 9560), and installing it. Haven’t figured out how to install a driver from a file though.
-attaching an ether to usb-a to my usb-a expansion card to start an online install of Endeavour (through Calamares), sharing the network from my desktop. Windows says it’s sending data over ethernet, and the Framework sees the ether network, but the Framework keeps saying it is disconnected (despite never saying it was connected), and Windows says it has received 0 bytes of data over the network share.

I’ve checked everywhere for what to do, I don’t remember where or what exactly because I’ve also been trying to fix my Windows PC which no longer wants to install updates, but still tries to update automatically, which is… not great haha. Anyways. The two issues have run together for me, if I remember anything else I’ve done I’ll add it. Continuing.

EDIT: I have a 512G SSD with ArchLinux installed on it from the Acer, and the Framework says there’s no bootable drive. When I run the Endeavour live iso, it says that there’s an arch partition, efi, etc etc etc, so i dunno whats up there. I remember having to turn off secure boot to get it to load the live iso too. I can send any BIOS settings I have if that affects what’s goin on

when I run lspci, it gives me:
Network controller: Intel Corporation Wi-Fi 6 AX201 (rev 20)

EDIT: sudo dmesg | grep iwlwifi gets me:

iwlwifi: No config found for PCI dev a0f0/1552, rev=0x354, rfid=0x105110
iwlwifi: probe of 0000:00:14.3 failed with error -22

Whether the 1550i is inserted or not. I’ve checked and rechecked the connection numerous times, to no avail. My working theory is I just need to buy a new wifi card because this one is incompatible. Which sucks because I need this up and running ASAP so I can do school stuff outside of my dorm room, i.e., in class.

EDIT: I have tried “modprobe -r iwlwifi” multiple times, there are a couple of the correct driver in the /lib/firmware folder (zipped and unzipped .ucode files), but nothing has changed functionality-wise.

That’s all I can think of right now. If you have any information, literally any help is appreciated! Even if you think “oh she’s already done that”, it’s very possible I have not! If you think I’m asking in the wrong place too, let me know as well. I just want this fixed haha.

Thank you!!


So, um, I don’t know much about these things, but as you haven’t had any other responses yet, I’ll throw in my tuppence worth.

I notice you said the output of lspci identifies the “normal” Framework wifi card. Now, as you’ve installed your own card, I assume you would have noticed if there was another card already in there. But maybe the driver for it came with the FW driver package or whatever and that’s what’s messing things up for you? Could you maybe try uninstalling the driver for the AX201 and see what happens?

1 Like

@FlyingFox.of.theYard that’s a good idea, I didn’t even think about the driver being pre-installed. cuz lspci -k does show like you said the other card’s info (which, as you surmised, yes, i would have noticed if another card was in there haha). So I can look into uninstalling and reinstalling drivers. Thank you so much! I’ll report back with my findings

1 Like

OK i’ve put the correct drivers into the /lib/firmware folder, and removed anything associated with the AX201, it’s still saying that’s what card I have though. I have class… well, now, so I’ll check back in a few hours what’s going on.

This is beyond my expertise, I’m sorry. All I can suggest is that you contact support and hope that either they or someone else here comes up with an answer soon.
Support should at least be able to tell you if the card is incompatible.

Good luck!

1 Like

I hate to say so, but I don’t think this WiFi card is compatible with your i7-1165G7 processor:

The AC 9560 and 9460 family of wireless (Wi-Fi + Bluetooth) modules are the first generation of CNVi modules.[3] They are only compatible with systems running Intel Gen. 8 or 9 processor on adapted motherboards.


@BluishHumility damn, that figures though. I guess I should have started with looking into whether it was compatable or not. I’ll find another card I guess haha. Thank you all so much for your help though!

1 Like

The Intel AX210 is for some reason way below market price in the Framework Marketplace–only $18!

I just checked and they are more like $30+ on Newegg, Amazon, Ebay.

I don’t know why they are selling them for $18 but I couldn’t be happier–works great out of the box on Linux (I’ve tested four distros so far on mine and haven’t had to lift a finger to get WiFi going on any of them).


@BluishHumility thanks! That’s great, I’ll order that right now actually