Still cannot use track pad fully

Recently, I replaced a motherboard on a…

  • Hardware: FW 13 DIY, 32GB Ram
  • Processor: 11th Gen Intel(R) Core™ i7-1165G7 @ 2.80GHz
  • OS version: Windows 11 Home v. 23H2 build 22631.3374

I installed all of the necessary drivers…

  • BIOS v. 3.19
  • Driver bundle W11_2021_12_15

And for some reason, I still am not able to use the trackpad for scrolling or right click. No settings are showing for trackpad settings, just mouse settings - that driver is from 2006 and doesn’t allow updates.

(1)I have uninstalled mouse drivers, and reinstalled them, rebooted, no change.
(2)I have downloaded the bundle from installed them as admin, then rebooted, no change.
(3)I have disconnected the trackpad, and reinserted to verify it is seated correctly. No change.

Is there any one that can think of why the trackpad still does not operate correctly?

That is the correct/same driver I have on my 1165G7. (21/06/2006)

Two finger scrolling works anywhere on the pad.
Right clicking is a physical press in the area 50% right and 30% up on my setup.

Maybe it is ‘correct’ depending upon your settings, but not as you want ??

Win 11 settings. . . . . .

Settings > Accessibility > Mouse pointer and touch > Touchpad > Scroll and zoom
Settings > Accessibility > Mouse pointer and touch > Touchpad > Taps

If all the above is set, and still not as options set, you may want to check the cables again.

I can confirm: Settings > Accessibility > Mouse pointer and touch > touchpad - there is missing settings that does not match similar devices.

I have more than 1 FW laptop. Both are Win11 Fw13 laptops, both with the updated driver bundle, on the same version.
The laptop without an issue is able to see the following options in settings:

  • Touchpad (toggle on/off)
  • Cursor speed
  • Taps
  • Scroll & zoom
  • 3 finger gesture
  • 4 finger gesture

The laptop with the issue, does not see any of these options, in the same settings screen. The laptop with an issue only sees “taps” in the settings.

Nearly had a scare, I toggled my touchpad off.
Tab brought up options, one of which was a [Reset]

So either your drivers are faulty or out of date etc. or the cable to the touchpad is faulty.

Will try and download the driver I am using.

Additional troubleshooting:
I completely removed the SSD (with the trackpad issue) to my alternate FW13 laptop that does not currently have a trackpad issue, replacing only the SSDs in this test - same issue. Using the hardware that I know works, the trackpad feature was not available. I updated the drivers. No Change.

Returning the SSD (with the trackpad issue) to the original hardware, I performed a full OS wipe and reset. Updated windows 11 to latest update, Installed driver bundle - No change. Trackpad still not functioning.

Performed another full OS wipe and reset. Updated windows, Installed driver bundle again - trackpad works. Confirmed all expected settings are available now.

(1) I confirmed it was not a BIOS issue by flashing the newest bios, as well as testing on a confirmed working device.
(2) I confirmed it was not a hardware issue by testing on a different device that is confirmed to have a working trackpad.
(3) I confirmed it was not a setting in the win11 profile, by using a completely new Win11 install without any personalizations. Performing a full OS wipe and reset, with the latest updates from MS.

  • The best I can determine, the driver bundle is not installing the trackpad drivers correctly/fully.
1 Like

Yes it could well be the driver wasn’t installed properly. I didn’t mange to extract it so glad you have resolved the issue.

It’s a relief :slight_smile:
All the best

1 Like