Touchpad is not working

I’ve downloaded the driver bundle and for some reason the touchpad is not working at all. I’m on Windows 11 pro. I tried to look in the BIOS to turn off the PS2 setting that I saw in one post but I didn’t see that option available. Anyone else have this issue or know some more troubleshooting steps to resolve it?

I have been having a similar issue and also been having an issue where my touchpad would disconnect and no input would be detected unless I pressed down on a corner of the plate. I solved it by moving the touch pad to a different connection plate and now everything seems to be working just fine.

When you move it do you shut down the computer first or do you leave it on? I guess how “hot swappable” are the components?

I’ve done both. But I would say doing it with power off would be best just to be safe.

So It looks like I may have some power issues with the connectors on the board

I just took it apart and adjusted the aluminum cover the connectors are on. My num pad is now working (it wasn’t before), but the trackpad is still a bust. I’ll keep trying to mess around with it as time allows

1 Like

So I left it on over night and had the battery completely drained. Went to use it the next day and the touchpad was working. No idea what happened, or how, or why…but I’ve got a working touchpad now :slight_smile: