TPM 2.0 not detected

I got my new Framework 13(Amd Ryzen), and in my haste I fresh installed windows 10 onto the laptop. Everything seemed alright, until I went to plug in my ethernet, and connect to my home wifi. Nothing worked, and I realized I needed windows 11… whoops.

I cleared the usb, and followed the guide to install windows 11, and thought I could just update from windows 10 to windows 11 and all would be fine.

I got the TPM 2.0 Error when trying to install, and also tried to boot just to the drive, and not through the statup in the file browser inside of windows 10. Still the same error that i do not meet the system requirements for Windows 11 (TPM 2.0 Required). So I tried enabling in the bios, but each time it seems to reset.

Any help would be greatly appreciated, and yes I am dumb for not reading the instructions and installing windows 10.


You’ll need to do a fresh install using a USB as the TPM requires a driver that is Windows 11 only.

TPM is part of the Microsoft Pluton processor, which doesn’t work in Win10.
If you search for “how to upgrade to windows 11 without tpm” you’ll find some tricks. No idea if it works, but I imagine it does.

And if it does work, Windows 11 should recognize the Pluton and download the correct driver. No idea if you have to undo the registry hack.

1 Like

This is because Wifi and other drivers are needed download link, not because of Windows version.

you have to bypass tpm check. if you figure this out, the update from working Windows 10 to 11 is running well and windows 11 installs the TPM an Pluton Driver. Please google “bypass tpm check inplace upgrade”