[TRACKING] AMD FW13 fan speed jumps up high, drops quickly back to low / off

The fans in my AMD Framework 13 spin up to a high speed, and then drop back down after 1 second.

This happens randomly when I am using it, when I am in any application. The fan noise does not seem to be regulated by lower fan speed to prevent such from occurring. It is sort of annoying when you are concentrating on a task and you hear a random bust of air coming from the system.

Also, does anyone’s AMD FW13 drain battery fairly quick while using Firefox? (Fedora version, not flatpak). Even when I have one tab open (this page that I am writing this post in) the system gets hot where it kinda starts to get uncomfortable. My power mode is always in power saver:

My CPU is currently at 101.84 F
38800 / 1000 = 38.8 C (101.84 F)

gxnni@necrozama:/sys/class/thermal/thermal_zone0$ cat temp

neofetch screenshot (since idk what else to share)


Same on Windows, fan is off most of the time and when it turns on its rather noise, so high rpm on the lowest setting and it modulates too quickly

1 Like

I’m glad that I’m not the only one, and that it might only be a Linux issue. If we’re both using AMD FW13, maybe it’s something to do with the firmware. Either way, it’s jolting when you’re super concentrated on something. Hopefully something about it is addressed.

1 Like

I recently spoke with support about this, and it is behaving as designed:

The fan speed is controlled by external temperature sensors outside the main APU. So it will take a longer time for the fan to spin up. The fan start temperatures are actually 40/46C. But the sensors are located further away from the main APU. You can see the configuration here: https://github.com/FrameworkComputer/EmbeddedController/blob/lotus-zephyr/zephyr/program/lotus/azalea/overlay.dtsi#L23

Perhaps future ec firmware versions will tweak the fan curve?

They should consider it. In my eyes, if the sensor is too far away from the main source of heat on the board, seems like a massive design flaw. If they need to adjust some values to make it not spin up as fast, that would be great. No other system that I have used crank up the fan to this amount, just for it to halt after a second. (don’t even get me started on the supreme thermal control on macbooks, because I do not want to compare apple’s to oranges) (pun intended) That would greatly increase the usability and customer experience.

The fan spinning up very high and then stop again after a second doesn’t sound like something that comes from a temperature control, especially if the sensor is a bit further away, where I would imagine the temperature to change a lot slower (because of thermal mass). Unless they have a fan-curve like “40C is off, 41C is full blast”, where it suddenly goes over 40 and then is under 40 again a second later.

So the fan spinning up full blast for a second sound like a different bug. Why does it even spin up that fast? If the temperature slowly raises on more or less idle-load, the fan should never need to ramp up that fast. It’s like the sensor goes “OH SHIT, IT’S REALLY HOT … oh wait, false alarm”.

1 Like

Thank you for your input. I believe that the threshold should be changed if this is the case. There should be tiers to how much fan speed is associated to temperature of the system. A gradual increase would be way better than a full blast (… for a second).

That is the question that I am trying to get an answer for! That’s the reason that I created this thread.

I don’t know if there are multiple sensors, for example in the link @46hawk posted, there is also cpu-f75303, which I don’t know where it is. But if that’s in the CPU itself (from the name of it), with temp_fan_off = <46> and temp_fan_max = <54>, which is a very small range. And on the CPU die itself, temps probably spike a lot more, even from some short background task on an otherwise idle CPU (which then goes down quickly again because of the thermal mass of the cooler). So maybe that fan-curve is too aggressive? :thinking:

Either way; it’s something that I am not comfortable enough to mess with just yet. If users are experiencing this regardless of host OS, this is something the manufacturer (Framework) should take a look at.

1 Like

I also have this little beast here and must say i’m happy with the noise levels. i also use firefox and it seems not to act like yours with the fan jumps. i also did a little browser benchmarking and it it started to give more cooling just in the upper 80 degrees (celsius).

but i must say - one of the first things i did after installing ubuntu and the stuff to make fingerprint sensor working was installation of auto_cpufreq - because on my ryzen 5000 desktop (windows) i also have this issue with permanent fan speed jumps. this is because of the aggressive boost overclocking and a sff enclosure.

regarding the question about multiple sensors or not - i thought of there are some more internal sensors for measuring hotspots in the cpu/apu but i cannot provide sources for this piece information (sorry about that).

Thank you for your response. I am also working on some out of the box Linux customizations. To assist myself in the future (in case I distro hop) I am tracking all of my configurations in a handy Libre Office file. I am daily driving Fedora for the first time on my AMD FW13, and it has been an interesting experience. Nice of you to mention auto_cpufreq. This is something I had recently learned about while doing some background research about power management on Linux. To my surprise, power management might as well be non-existent on Linux since it does barely anything (at least with the default tools). I first heard of the auto_cpufreq package from the Chris Titus Tech YT channel, where he covered the benefits of using it. From what he described, it looks fairly promising and I think I may check it out:

However, I hate to be the bearer of bad news, I don’t think this will address the rapid spikes in fan noise. Though it may help place a band-aid over the issue at least. I cannot say for sure, before I do more testing of my own.

Thank you (again) for your comment either way!

you are very welcome!
i like the idea of documenting the steps needed to create a reproducable workable linux installation on your baby! :slight_smile:

i also throught about that but in a more technical way (what i did not go so far). in my job our sysadmins use a tool called ansible to make such states reproducable by just running a “playbook” what is basically a configuration unit in a certain format. but i did not start with it yet.

when you are speaking of fedora - there is another post in this forum about OCI images - this is another step further by just creating dowloadable ready to use fedora images for the framework laptop with certain hardware configurations - but i think they are in the beginning of that topic. maybe you can provide your docs there :slight_smile:

link to the topic: Custom Fedora OCI images for Framework laptops

have a nice evening!

Very cool! At my job, imaging software is only used for Windows systems.

I’ll need to check it out! A lot of this is so new to me (especially the concept of Linux images), so it will probably take a while before I can make meaningful contributions. Of course this is something that is possible, considering everything in Linux is a file. This is def something I should look in to more. If I can contribute to open source initiatives that make my life, and everyone else’s easier, I am all for it!

1 Like

Tracking this. As you have new details please update it here. Thanks


I’m just weighing in here to say this is happening on my AMD 13" on Arch Linux also.


Also experiencing this in my AMD version with Ryzen 7640U. Happens once every 1~2 minutes. Not a big issue of everyday use, but I am a little wary about the potential impact of battery life since the moment a fan starting to spin is the most energy-consuming one to my knowledge. I wonder if the fan control can be smoothed a little bit to prevent it from being toggled frequently.

I’ve got the 13 AMD FW running Windows 11, all latest drivers (ones from the AMD site) and BiOS and it does this to me as well. Fan spins up to max for 1 second and then immediately stops. Laptop doesn’t even seem that hot and I don’t have much load on the machine – it has happened when I was just doing some very light web browsing in a 68F room.


I don’t have too many additional details to add at the moment, but I’ve had this happen to me too, in both Windows 11 and Arch Linux/EndeavorOS. The timing and frequency tends to vary pretty wildly in my experience, sometimes it might only happen once or twice in an hour long session, sometimes it spikes once every minute or two. I haven’t really put any time into figuring out if it depends on e.g. power saving settings, if the laptop is plugged in or not, etc., but I’ll pay more attention to these going forward and add details if I figure anything out.


I am seeing same fan behavior. I believe it make sense. Fan is off and temperature is slowly rising. Once it reaches some threshold, FW decides - it’s time to start fan (at lowest speed). Running fan causes the temperature to drop below threshold so fan is shut down. This repeats every few minutes.

And the fan speed spike? It’s “kick start”, where fan is started into higher speed for a moment and then it’s dialed down to expected speed. This is quite common, because fans are often not able to start into low speeds, but once spinning, they can be lowered into such speeds.

I believe that fan kick start is too aggressive here - too long and too strong.

1 Like

I’m not sure how true that is of PWM fans, and even when using just voltage range to control a fan it still isn’t necessary to kickstart it at full pelt.