[TRACKING] Instant power loss

@jsh the list is unfortunately growing. I guess your experience blows the “1 stick” theory. Mine was not plugged in, light duty just typing, I had already updated to 3.07 the night before.
Just trying to muddle through and taking stabs in the dark what’s causing this.
The good news, at least for me, only happened once.

This just made me realise another obvious benefit that companies get from NOT offering more user freedom: support/troubleshooting is much easier when there is only a small set of possible configurations, both on the hardware and on the software side. Of course Framework tries to counter the software side of this effect by advising to only use officially supported OSs, but I still bet the support resources allocated to their prebuilt models are minimal compared to those allocated to us strongly willed DIY/Unix enthusiasts (although this particular bug seems to affect both). Kudos to the Framework team for putting up with that challenge, I’m sure that even with all their experience, they underestimated how diverse support requests for (essentially) one product and its parts could be.


+1 on instant power-loss under load

Started from full battery ~98%
Laptop Batch : October 2021 DIY
CPU: Intel® Core™ i7-1165G7
OS: Fedora 35
BIOS-Version :" sudo dmidecode -s bios-version" → 03.02
factory default

Under load whilst unplugged on dolphin emulator resulted in sudden power loss.
Turned it back on with 80% battery left (didn’t have to hold power button long in-order to reset anything).
Fan made a weird noise just before power shutoff.

Try doing the ram shuffle, told to by support.

Still occurring. I saw on another thread someone mentioned being related to their hard drive. Believe they replaced it and stopped reporting back.

This did seem to get worse around the time I added my SN750 to the laptop, but I have yet to try removing it again.

Given this thread I’m wondering if the issue is actually caused by SN850 rather than memory or the mainboard itself.

Could someone with a spare SDD try swapping it out to see if it makes any difference? I have another SDD but I’ve experienced power loss only once, so it would not be very informative in my case.


As Korvin mentioned, i had a buch of weird BSOD and freezes/crashes while I was running a Wester Digital SN850 (with updated firmware) with Windows 11. The Framework support person was convinced it was a DRAM issues. I tried 3 different set of DRAM before trying a different SSD. I tested my laptop on an old SK Hynix SSD then a newer and larger Crucial P2 and all the bugs disappeared.

1 Like

It can probably explain my case as well. When I connected a USB memory stick that caused some sudden SDD activity as it usually does. SSD consumes much more power when writing data, so that could result in a sharp spike of power consumption. If power regulators are faulty or not powerful enough it theoretically could cause brownout and similar issues.

We can probably stress test the system by crafting various power management scenarios to see if it makes any difference.


This just happened to me as well. I’ve owned my Framework for just under 2 months now and hadn’t experienced this issue until just a moment ago.

I was sitting at 71% battery life, not doing anything intensive. I had just published an npm package, and used my yubikey to authenticate. The laptop shut off a few seconds after unplugging the yubikey, no idea if that’s in any way related though.

Nothing I was doing at the time was intensive, and all of my tasks were complete at the time it shut off, so the laptop would have been in an idle state.

I was charging my phone from the USB-A port. So that would have reduced power available to the laptop I suppose? Though I would think the firmware would be configured to now allow USB devices to drain enough that the laptop cannot continue to run.

I also have the Western Digital SN850 SSD. Has anyone been able to confirm if the issue is with the SSD?

reminds me of a medion (iirc lenovo) laptop my sister used to have (win xp era). reasonably usable, ok ish cheap laptop, ~3 hours of battery life. Unless you opened windows media player, that caused an instant power off. every time, regardless of the battery status, and the machine would not power back on without being plugged in because the battery was dead. 0%, even if it had been 100% 2 seconds before you opened wmp. so long as you didn’t open wmp you’d get a few hours out of the battery.

We never figured it out.

I dunno if it’s worth much more than an anecdote, but … raises hand … yeah, I’ve seen this too. Not in the past day, but in the first out-of-box of my brand new Framework laptop – no idea what batch, that wasn’t anything I could find on any packing or docs, but I just got it yesterday and it came with 3.07 – it shut off unexpectedly 3 times, I think!

At first, I figured it may be because I was using its first battery charge, and it was lower than it thought it was. But I turned it on again, and it was still half full. I continued on, and just while mousing around a website (computer sitting on desk, finger lightly touching touchpad), boop. Off. As others had noted, mine was similar to those: complete unexpected power-off, no hibernate, no sleep - rebooted from crash to amnesia.

After I installed the Framework driver pack, it hasn’t happened since - even after ditching Windows 11 for Windows 10 on a clean wipe/reinstall.

To me, it was somehow related to needing that driver pack… badly. Don’t mouse on without it! :joy:

I’ll add to the anecdotal evidence - I also had it happen a few times when I first got the laptop. I’m not sure if it was the driver installation or the BIOS update that fixed it. I also have the Intel Driver Support Assistant installed to keep the drivers up-to-date, and there have been a few driver updates from Intel in the last weeks. I have a Batch 6 laptop.

I just had an instant power loss for the first time. My laptop is a batch 3 professional model that I’ve been using since the beginning of October.

The laptop was plugged in and 100% charged. I was just typing in Visual Studio 2019 when the screen shut off and the power button went dark. This wasn’t a blue screen, at least according to the Windows event log and lack of new memory.dmp file. The only system errors I see are

Event 6008, Event Log: “The previous system shutdown at 4:13:28 PM on ‎2/‎15/‎2022 was unexpected.”


Event 41, Kernel-Power: “The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.”

Just yesterday, I updated from BIOS 3.02 to 3.07. I’m not sure if that’s the variable here, but I’ll say again that this is the first time that this has happened to me. I also updated to the 12_16_21 Windows 10 driver bundle last week.

@brianshmrian That’s not fun. Have you got a WD SSD? If so, have you updated the firmware? There was some issue with it where it would suddenly stop working. I was wondering if that could also be the cause of the sudden power losses. I know that I updated it fairly early on, so that might also be why my sudden power losses stopped.

@Ruurd_Offringa According to the Western Digital Dashboard, I have a WDC PC SN730 SDBPNTY-1T00. The dashboard says that the firmware is up to date with version 11140000. So far the power loss has only happened once, but I’ll report back if it happens again. Maybe it was cosmic rays. We can always hope for cosmic rays.

Hopefully it was cosmic rays :slight_smile: and it doesn’t happen again.

1 Like

I’ve had My framework DIY kit for about 2 hours and this has happened to Me 3 times. First during Windows Update (fans were running heavy).

Second while installing the Framework driver pack as recommended in these threads, and 3rd while Idle.

No physical contact with the machine when it happened. Alone on a table, no electronics within 10ft

2TB Saberent: SB-ROCKET-2TB
2x32 ddr4 3200 g.skill: F4-3200C22D-64RS
Intel Wifi 6: AX200NGW

Anyone have suggestions? I don’t really want to return it, love it so far.

@Thomas_Bruno It is a bit disconcerting - I also had all of these with my DIY kit in the first hours, but haven’t had once since. Once you finish installing all the drivers (as well as the updated intel drivers) and made sure your SSD firmware and the laptop BIOS are up-to-date, the problem that causes these power losses should be resolved.

1 Like

Hello everyone, I myself am a computer science student from Scotland. I have yet to get a Framework for myself but have been recommending it to all my friends. A month ago my Canadian friend ordered one and finds it great. Initially we got her to install Ubuntu and everything seemed to work except one major issue. Like once a day it would suddenly poweroff without warning. That’s regardless of whether it was plugged in or not. We initially got her to flash the 3.07 BIOS (it came with 3.06 I believe) that didn’t help. We then switched her over to windows 10 21H2 still the same issue. 3 days ago she used the support form to contact Framework but still has heard nothing back then once again yesterday. Is there a Phone number she can use or can any of the Mods help her get in touch with the team? I think she just got a defective unit unless anyone has any other information. FYI it was the DIY edition i5 Both ram and SSD were from framework.

I’m having similar problems with crashes/lockups with my new framework laptop in both Windows11 and Fedora35. I’ve attempted to submit to support using multiple combinations of laptop/OS/browser, but have failed every time with Captcha failures. A friend had similar captcha failures but was successful with Chrome on a MacBookAir, that didn’t work for me. I have DIY i7 with SSD and RAM from a different vendor