Trouble connecting to EGPU

So, I’ve had a Sonnet Breakaway 750 that I’ve been able to use with my old ThinkPad P51 without issue until that laptop recently died (No longer able to display on any sort of monitor laptop included). Hence I purchased a FW laptop. I had absolutely no issue connecting the Sonnet to the ThinkPad, outside of getting the right drivers for the graphics card.
My FWL just came in, and after I got all the actually important stuff setup. I’ve been trying to get it to connect to the Sonnet with no luck.
I’m able to get power out of it, and the PSU on the box is running. But absolutely nothing else is running. When I am able to get it to connect all I get is this message and the Windows 10 list of solutions.

image

It can read that it’s connected, but the Sonnet doesn’t light up, or do anything else it should be doing when connected.

any tips, tricks, or advice from all you lovely people, other than trying Linux?
I don’t think I’m the first to experience this problem, and I’m pretty sure I won’t be the last.
hopefully, we can figure this out so that we can better guide new FWL buyers.

i figured out the problem, somewhat.
I switched out the TB3 cable I was originally using and swapped it with the cable the Sonnet came with. Everything worked perfectly once i did that. There was probably a problem with the cable itself that i was using. although it worked with no issue on my old laptop. bit of a shame since I did spend a bit to get a supposedly good cable.
also took a good while to dig the box out to get the cable.

Hey @danyal_syed, glad you figured it out. Was the other TB cable that you used longer than the one that came with the Sonnet? If so that might have actually been part of the cause!

Yeah, it was a 2m cable I grabbed from Amazon. I purchased the cable because it was “supposed” to be properly specced out for what I would need. The one that came with the Sonnet is like 15cm or something close to that.
this is the one I had purchased, I think I got a bit cheaper than what they’re currently asking back in May, worked perfectly out of the box with my old P51.

got a feeling it can’t actually do both power delivery and the data passthrough required at the same time, or I just got a somewhat faulty cable.