Trusted Platform Module is not Accessible

I’ve noticed a funny issue recently with my Framework laptop that seems to be BIOS related. I partitioned my hard drive into 3 partitions (work, personal, and shared). My work and personal partitions each have Windows 11 installations that I can boot to. I usually use my laptop plugged into a docking station (CalDigit Thunderbolt 3) and if I restart the device while it is plugged in (plugged in, shutdown, plugged in, turn on) then everything works fine (Windows Bootloader appears with the option to boot to work or personal). However, if I shutdown the laptop while plugged into the docking station and then turn it on when it is NOT plugged into the docking station, I get blue screen at start up like this:


If I press F11 at this screen, then I’m taken to the screen where I can choose which partition to boot from, so it’s like there’s not really an error after all? I have BitLocker enabled on my work partition and that partition is the default one in the Windows Bootloader, but the error message about the Trusted Platform Module not being accessible makes me wonder if it’s BIOS related (I have BIOS 3.03 installed). I’ve searched around online and some people recommend that a BIOS update might fix the problem. I’ll test today if it’s only when I’m plugged into the docking station that the issue happens or if I can reproduce it when it is just plugged into the power adapter.

I just tested this, and it does not reproduce if I’m just plugged into the power adapter. It only seems to reproduce when I go from plugged into the docking station and then not plugged into the docking station.

My guess is that the TPM built your hardware key based on the dock you are using. When it is not present at boot the TPM notices the change and asks you to authenticate.

Not sure of a solution, other than disabling bitlocker, and re-enabling it with the dock not present.

4 Likes

Thanks for the suggestion, @2disbetter. Unfortunately, that didn’t solve the problem. I have a good workaround for now, but hopefully a future BIOS update will solve the issue.

That is good. I should have mentioned that you needed to reset the TPM in the BIOS, before re-enabling bitlocker just to be sure.

Still if you have a workaround for now, I’m not sure it is really worth all the effort.
:+1:

@Daniel_Schulte is this a thunderbolt dock?

It is a Thunderbolt 3 dock. I didn’t reset the TPM the first time I tried to apply @2disbetter’s suggestion, so I tried it again with a TPM reset. I think that might’ve fixed the problem, but I’m unable to test it at the moment.

1 Like