Ubuntu 22.04.1 - Logitech MX Master won't pair

I’ve spent a few hours now trying to pair my MX Master 2S with my 12th Gen Framework running Ubuntu 22.04.1. I’ve paired other bluetooth devices to the laptop without issue and my MX Master pairs fine with my other computers…including my AMD desktop running Ubuntu 22.04.1. This is why I am leaning towards this being a hardware issue

I’ve tried normal pairing via GUI Settings and also trying to manually pair using bluetoothctl with the mouse’s MAC address. It simply cannot detect the device. I don’t have a receiver for this mouse so Solaar isn’t a solution. I’v updated bluez, restarted bluetooth via the command line and various other solutions posted on Stack Overflow to no avail. Any ideas before I buy a new mouse? Thank you for your time

Like usual as soon as I make a forum post I find a solution, deep in Stack exchange with no up votes. I changed the controller mode to “dual”, rebooted and it works now. Credit: Bluetooth connection fails by connecting to the Logitech MX Master S2 mouse - Unix & Linux Stack Exchange

Feel free to delete this post but I’m thinking somebody may find it helpful in the future.


Also, this same thing applies to Airpods, too. Same exact tweak. :slight_smile: Glad you have this resolved.