Ubuntu 24.04 on the Framework Laptop 16


The installation guide is available here: Ubuntu 24.04 LTS Installation on the Framework Laptop 16 - Framework Guides

Optimizing Ubuntu Battery Life

Intel users may want to begin testing against TuneD. AMD, do not use TuneD or TLP - stick with PPD as it comes by default.


We’ve had folks doing so without trouble. However, as always…always, always, always have a backup of your important data.

  • Disable PPAs (likely not needed, but a good practice.)
  • Always make sure you’re fully update BEFORE upgrading.

sudo apt update && sudo apt upgrade -y && snap refresh

  • And as always, upgrades can fail. Generally rare, but this is why we backup - just in case a fresh install is needed.
1 Like

Has anyone noticed any issues with the touchpad on Ubuntu 24.04? The touchpad on the Framework 16 laptop rarely works for me. Only sometimes does a boot show a configured, working touchpad in the settings. I haven’t seen these issues on Fedora 40 though.

The fact that this hasn’t happened in Fedora 40 is interesting. If this is easy to reproduce, try the following:

  • Attach a mouse. Boot up, open one terminal window.
  • sudo apt update && sudo apt upgrade -y && snap refresh && reboot
  • Still happening? Keep going. Boot up again, open two separate terminal windows.
  • In one, journalctl -f and in the other sudo dmesg -w
  • Do you see anything regarding the touchpad being spammed (anything you can copy and paste into a text file using your mouse)? No? Undo the locks on the left and right side of the FW16, while booted, detach the touchpad - reinsert, lock again. Did this help? If yes, this may be a power management issue with the touchpad with your configuration.
  • Confirming no changes or tweaks were made to power management (No TLP, etc)

FYI, Ubuntu hasn’t made the official 22-24 upgrade available yet. So I tried the upgrade from from 22 → 23 which seemed to work but 23 → 24 failed, so I just reinstalled 24. No big deal. I didn’t do a lot of analysis, but my random guess would be the proprietary AMD GPU drivers I installed. Important safety tip. So far 24 works just fine for me, graphic, sound, touchpad, etc. all work as expected.

Thanks for the information. Unfortunately (or fortunately?), I have not encountered the touchpad issue on Ubuntu again this weekend even though I have rebooted and switched between Fedora, Ubuntu and Windows 11 several times. If it ever does arise again, I’ll be sure to try the steps above you mentioned. Unfortunately, due to the nature of the problem, it will be hard to point to a particular action as the cure, but I’ll sure try.

I am having the same issue with the trackpad sometimes not working when I boot up the machine.

1 Like

we have two FW16 in the family, tried arch linux and ubuntu 24, both laptops have touchpad issue intermittently. Works fine on windows 11.
The easiest way to reproduce I found so far is turn on, do not touch anything until the OS password prompt, restart from that screen. Keep restarting, and 1-2 times out of 10 touchpad won’t work

1 Like

I’ve just tried this and at first I thought it worked, I restarted maybe 15 times. But then I logged in, shutdown, and after restart it didn’t work again…

1 Like

xinput list
WARNING: running xinput against an Xwayland server. See the xinput man page for details.
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ xwayland-pointer:15 id=6 [slave pointer (2)]
⎜ ↳ xwayland-relative-pointer:15 id=7 [slave pointer (2)]
⎜ ↳ xwayland-pointer-gestures:15 id=8 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ xwayland-keyboard:15 id=9 [slave keyboard (3)]

I installed kubuntu 24.04 yesterday and today I’ve been experiencing the touchpad issue.

1 Like

I had this issue a few times a week ago, though it seems that this issues sometimes resolves themselves after logging out and logging in (luckily I can use a mouse or press window+L and relogin by keyboard) again or rebooting the computer.

I cannot fingerpoint a possible cause of this problem though…


Appreciate it everyone. The absolute best thing we can do is if we see this again is to try and capture it or if it’s really bad, force a reboot and capture the previous boot logs. Try to write down the time it occurred, open a ticket and run this.

journalctl -b -1 > previous_boot.log && tar -czvf previous_boot_logs.tar.gz previous_boot.log && rm previous_boot.log

Grab previous_boot_logs.tar.gz from home directory, when support asks for your logs and provides instructions, include previous_boot_logs.tar.gz insead (again, assuming you forced a reboot).

The 24.04 Installation guide links to Optimizing Ubuntu Battery life (Optimizing Ubuntu Battery Life), which in turn links to Power Profiles Daemon step 3 (linux-docs/ubuntu-22.04-fw-16.md at main · FrameworkComputer/linux-docs · GitHub).

That page is written for 22.04 rather than 24.04. I have two questions about this:

  1. can I just follow step3 without installing the OEM-D kernel.
  2. if not: is there an oem-d kernel for 24.04 (can’t find it) or would the oem-a for 24.04 also do? (don’t know the diffrence)

Hi Rob,

The optimization article has been updated - just being fully updated will have you in the right place.

For Ubuntu 24.04, you will use the default generic kernel at this time. OEM is only needed for 22.04.

1 Like

Does anyone have issues with the dGPU since moving to 24.04? I upgraded to it and since then the display won’t turn on if I boot with the dGPU installed. It will turn the display on without the dGPU. I’m unsure if the screen is just off or if the boot sequence is hung up on something.

Hi @Matt_Hartley . It happened again to me on Ubuntu 24 with the touchpad not being recognized. I have a running thread with Framework with some USB-C port issues I’m seeing sporadically on port #2. Since they had mentioned my Linux Ubuntu touchpad issue in that email thread, I have attached the previous boot logs and mentioned your name in that email. Hopefully, you have access to those emails. The subject is: “USB-C port issues, Framework 16