USB C is not compatible with iPhone 15 / Pro / Pro Max

Hi,

I tried tethering my iPhone 15 Pro Max earlier today and discovered a frustrating incompatibility with my Ryzen Framework 13 laptop. I’ll let the video explain the issue:

1 Like

Do you have a control, say another laptop / PC, as a baseline?

:rofl: yes, tethering works just fine on other devices. FWIW, I experienced the issue in both Windows and Ubuntu, so it’s definitely a hardware issue.

Better you describe the issue. I don’t know if a lot of people are willing to try to figure out what the video is showing. I gave it a shot, replayed it a couple times, all I got is that you’re getting popups. Not only is the text tiny, but the popups appear and disappear quick.

7 Likes

What I think is happening:

  • The iPhone tries to provide power to the laptop
  • The laptop then swaps into charging mode and disconnects the USB device
  • The iPhone detects a new USB connection
  • The cycle repeats

In this case, the laptop is at fault because it defaults to accepting input power rather than negotiating USB first.

What does the Framework and iphone popups say?

Does this happened every time, without fail, when you connect the iphone using a USB-C to USB-C cable?

Without analyzing the communications, one can only guess at what’s causing this, or if you’d like, which side is at “fault”. Though less likely, it’s also possible that there are bugs on both sides, combining to cause this.

The iphone should not be just providing power when connected. USB-C doesn’t work like that for dual role devices such as a phone and laptop. Who takes on the provider or “source” role has to be negotiated.

Were the connector on all devices a full featured usb c (especially able to accept and provide pd charging)?

They’re negotiating, all right! Just being difficult about it.

I would assume this is an issue on Framework’s side unless someone has heard of this occuring with other laptops.

I would also check with a different cable if you didn’t already.

There have been other reports of the iPhone 15 having issues with trying to charge connected devices instead of accepting a charge, including the phone completely draining connected to a power bank. The iPhone 15 Pro has a weird USB-C charging problem | ZDNET

7 Likes

Try a different phone, non-Apple, to see if it still happens. This will confirm if it is the phone or the laptop. My assumption would be the iphone as Apple has a very poor track record for compatibility with anything outside Apple.

5 Likes

There have also been reports on this forum about this same kind of behavior being exhibited by different devices. I can’t recall if they were also iPhones or Androids but I do recall tethering issues

I’m curious if the new PD firmware in the 3.03 bios release changes the behavior.

Just tested this. It does not.

You can use a USB-A to USB-C cable, that’ll probably work fine, as USB-A can be used in only one direction (power wise).

Alternatively: Is there an option on the phone to select the USB-C mode? I know with mine (Fairphone 3 with Android), I can select which way the charging direction should be when I plug in an USB-C cable.

1 Like

I agree that this is a solution, but the product is still not working as expected and should be fixed.

I just tested this out on my computer. Intel 13th gen version of the FW13 and an iPhone 15 Pro. The computer is running Windows 11 and the phone is running iOS 17.1.

I tried USB C to USB C cables at USB 2, USB 3.x and USB 4 speeds from various manufacturers, including the one that came with the iPhone. All provided the same result: Windows mentioned that it might not be providing enough USB power but the phone said it was charging. So I don’t have the perpetual renegotiation issues in the OP. However, no network adapter appears in Windows. I also tried a USB A to USB C cable and it exhibited the same behavior, although without the USB power warning. I do not have iTunes installed so it’s possible that’s an explanation.

I’m not particularly concerned about this issue myself, as I tend to tether via WiFi. However, I wanted to add some more data into the mix.

2 Likes

Can you share a Picture of your settings in your phone menue?

(edit:How can I tether an iPhone to a PC via USB? - Speedify Knowledge Base)

@TheTwistgibber can you please comment on this? I’m still unable to tether to my phone via a USB-C cable! It’s been several weeks since this was reported!

I am seeing the exact same behavior. How could we see which device is at fault? My AMD FW is the only device that has issues with my iPhone 15 Pro Max.

I think you would need special diagnostic equipment to view the PD communication going on. And knowledge of what the proper communication is according to spec.