USB-C/Thunderbolt Dock Megathread

I only charge my laptop through the thunderbolt port, not data ports but yes I do have a HDMI screen connected at the same time.
Actually I vaguely remember having blinking issues when I tried powering a raspberry pi through the data ports.

Oh, one last question - 11th or 12th gen? I just got mine this week and it’s a 12th gen.

Received my framework (gen12) yesterday, and had been using the i-tec (CADUAL4KDOCKPD) Dock previously.

I have been able to get this to work without any problems now on Ubuntu 22.10 (beta) with the 1.12.0 evdi driver. I am using one of the HDMI ports too, so far not had any problems. It’s my work laptop, so will know next week how well it goes

12th gen 1260p.

1 Like

I’d love some help diagnosing dock issues on my Framework with Ubuntu 22.04.1 LTS. I’ve tried two different docks now (Caldigit TS3 Plus and OWC Thunderbolt Dock) and gotten the same issues, so I’m pretty sure it’s the laptop (or an Ubuntu config issue) and not the dock(s).

  1. Failure to wake from sleep. Most though not all of the time with either dock, when the laptop is closed and docked, hitting keys on the external keyboard and clicking the external mouse does not succeed in waking the laptop and turning the monitor on. I usually resort to opening the laptop, but often when I do that I run into…

  2. Failure to correctly recognize the resolution of the external monitor. I have an LG 34BK95U-W widescreen monitor with 5120x2160 resolution. When it works, it works great. But about half the time on either dock, when I do wake the laptop the screen will be distorted in some way-- sometimes a severe distortion that makes the screen unreadable, sometimes just a failure to recognize 5120x2160 as a resolution option. Disconnecting and reconnecting the laptop from the dock cable sometimes but not always fixes this. Restarting the laptop consistently does fix it, but it’s a pain to have to do that so often.

Any ideas?

Number 2 is a bug:

As for this, you might want to give the TS4 a try:

(Matthijs thinks it might be due to the difference in TB4 certification)

Thanks, @Second_Coming , that’s really helpful. Larger question: does Fedora seem in general more dock friendly than Ubuntu? Happy to switch distros if it’ll reduce the incidence of these gotchas.

I picked up a Comsol 2x HDMI dock in Australia and that seems to be working fine on Win11 on my FW.

It is marked as end of life, but there is 3x HDMI that has replaced it. It’s driving my monitor fine, as well as audio duties and USB-A. Pass Through charging seems fine as well.

I picked up this Anker 7-in-1 hub. https://www.amazon.com.au/gp/product/B07ZVKTP53

Will document in this post as the testing progresses.
So far:
Fedora 36: pass-through charging works, HDMI works

Maybe my post is slightly relevant.

I use the docking station of my old laptop, a Thinkpad USB 3 pro dock.

It works only mediocrely, because the connection is only established when the station is plugged in during the boot phase. If the station is already plugged in during boot-up, the screens remain black.

I’d like to report that the initial impressions of the Lenovo ThinkPad Universal Thunderbolt 4 Dock are good. It works with my two 1440p screens attached to the DP ports on the dock while also passing through the QNAP 10GbE SFP+ dongle I attached to it. Running Kubuntu 22.04.

2 Likes

I have at least 3 issues with the Belkin Thunderbolt 3 Express Dock HD with my 12 Gen Framework laptop (original 3.04 BIOS, latest available drivers etc. using Windows 11).

1) Power: I had the same experience as @Wade_Richards describes in reply #177 w/the power delivery. With just the Belkin dock connected for power, Windows shows it as charging - but it will slowly discharge the battery. after about 8-9 hours, the battery will be depleted, unless a second power supply is connected. I am currently using an Apple 87W charger to supplement; it’s super weird to have multiple power supplies connected to the same computer.

2) Second display won’t maintain connection: I have two external displays: an LG 4k and an ASUS 1080P. The Belkin dock only has a single DP port + an additional TB3 port.

  • I connect LG display to the built DisplayPort in the Belkin dock, and that works without issue.
  • However, I can only get the ASUS display to work reliably when I connect it directly to the Framework USB-C->HDMI snap-in port.
  • Behavior when the ASUS display is connected via the dock’s TB3 port using either USB-C->HDMI or USB-C->DisplayPort dongles: the screen continuously blanks out (appears to be constantly re-syncing or something like that) every few seconds - totally unusable.

3) KVM connections aren’t reliable (trouble both docked and undocked). I’ve had nothing but headaches trying to use three different KVMs - especially when connected to the Belkin dock. I have to connect any KVM to the USB-A snap-in module to get it to work at all - and I am currently only using the USB for K and M, and manually switching the second display in order to be able to keep my desk from becoming a hellscape, lol.

Generally speaking one would like to use a single TB/USB-C port connection to any laptop, and let the dock do its job. I’m hoping that the upcoming 3.06 release will address all of these issues - hopefully the TB4 certification process will iron this stuff out. Thanks!

1 Like

I have a Razor Thunderbolt 4 dock (https://a.co/d/gqRt8BC). Charging (90W), displayport via Thunderbolt (one monitor 4k@60Hz), USB, the SD card and the audio out all work. It works with both Linux on my Framework and OSX on my macbook pro.
Interestingly, the audio device only appears when you have something plugged into the combined mic/earphone jack. This is clever, as you can’t have the audio output going to the device when there’s nothing plugged into it.

OK… So I’ve been running this since I’ve got my FW, and it’s been great…

What has been the problem is my older Logitech K270 Keyboard and Mouse - they don’t like being plugged into a Hub (in fact, Logitech it turns out say not to…) as the keyboard drops out frequently. Fault of neither the FW or the Hub, but the keyboard - something to be mindful of.

It’s working better plugged into the USB-A on the FW, but still not 100% (so I think I’m off to find a new keyboard in town today as I need to write a load this week at a desk)

Just something to be aware of when trouble shooting docks if they’re being awkward…

1 Like

A little update to my earlier post: One problem I’m encountering from time to time is that one of the screens will start flickering after a protracted high speed network transfer. I’m not sure if this is a problem with the dock or if it is caused by the QNAP SFP+ dongle being attached to the dock.

I have bough the Lenovo ThinkPad Thunderbolt 3 Dock Gen 2 (40AN0135US) and am driving two Full HD Monitors with it. So far so good, but I recently noticed some weird coil whine, but not from the dock, but on my framework 11th gen. I guess it is because of the power supply and I am only having the coil whine when plugged into the docking station. Using my Aukey charger works fine here. Am I doing something wrong here, or is just like this and I have to deal with it?

Your dock should have a charger from Lenovo and a thunderbolt connector that likely has a little square on it. That one should be power delivery and thunderbolt connection to the laptop. Also coil whine is often an intensely personal observation. If you are experiencing it, and everything is hooked up correctly it is very likely that the particular model of device is delivering power in just the wrong way. I would say, either deal with it or get a different dock.

I am testing the Lenovo 40B00135US dock on Windows 11. (This is the same model as @0nn0 above - as far as I know, the US or EU at the end are not significant for the device, only for the power cable.)

Since I didn’t want to spend so much, I bought a used dock for my testing instead of a new one.

Sometimes when I plug in the dock, it seems to work perfectly. Other times when I plug it in, the charging light alternates between on and off every few seconds, and the list of connected devices in Device Manager keeps refreshing.

At first I thought the TB4 cable that came with the dock might be defective, so I tested with a brand new (certified) cable. The first time I used the new cable, it worked perfectly, but after that it did the same thing - appearing and disappearing every few seconds.

I was able to get it connected for long enough to upgrade the firmware in the dock to see if that would fix the problem, but it did not help.

I am trying to figure out if this means this specific dock is defective (and I should return it and buy another one), or if I’m missing anything.

Any thoughts?

Thats the exact dock I use, though I don’t use windows. My experience with the 11th gen framework laptop on both Linux and FreeBSD is I’ve been having approximately once per day my dock will disconnect for a second causing my screen to flash black and my USB devices to disconnect, and then it will reconnect and everything will go back to normal. So thats a far better experience than what you’re describing which makes me think your dock might be defective. I don’t experience this with my steam deck plugged into my dock but I haven’t tried other thunderbolt devices. I just plugged in a replacement cable (going from 2m 20gbps passive thunderbolt 3 cable to 2m 40bps 100w active thunderbolt 4 cable) to see if that changes anything.

Edit: And my screen just flashed, so the cable can’t be the problem. That leaves the dock and the framework laptop as possible suspects.