USB-PD 15V mode issue

If you’re running into that issue, and only want to carry one charger, you can always do what I do: carry a 60W 5/9/15/20V charger. and use that to charge your Framework, Switch and/or other devices. A properly made device should always negotiate down to what it can handle… Right?

It’s not exactly a workaround, nor is it cheap if you don’t own a 60W charger, but it does address the one-charger issue.

1 Like

Doesn’t address the issue of USB-C batteries though :slightly_frowning_face: I have a small mountain of high power USB-C wall power supplies, but in the car and away from the mains, 30-45W is as good as it usually gets…

1 Like

Yeah, if this is a hardware limitation you should look into disabling the 15V profiles and only claim to support 9V or 20V (if available).

Half of the chargers in my house are 45W (with 15V/3A as the highest voltages supported). It’s super fustrating to plug it in and see it discharging.

Losing the 15 Watt charging option would be an issue for me because I use that in my car. I hope it gets fixed soon

1 Like

We are thinking to offer an option to disable 15V source negotiation in the bios to allow charging from these chargers and negotiate a lower voltage in a bios update.

If you are interested in the parts that are impacted, they are PQB10 and PQB11 on the bottom side under the fan.
image

The good FET is AON6354 1N DFN5X6-8 -D
Please note these fets have a large exposed pad under the package, and there is some via stitching to other layers.

10 Likes

Thank you Kieran. Those pics and part numbers are awesome.

Did I find the right part on digikey? I guess it’s super out of stock (42 week lead time).

Yeah, I guess a rework would be doable for me and dnschneid (assuming we can get the part), but not a lot of other people.

The BIOS option to disable 15V would be appreciated (though it would be cooler if you could autodetect it based on SKU or something if that’s encoded anywhere).

2 Likes

You could try checking Octopart
https://octopart.com/search?q=AON6354&currency=USD&specs=0

If you wanted to search for alternate parts, the AON6354 has a gate capacitance of 1330pF, but the other source with the issue was around 2806pF. So if you found a similar part you could probably sub it in. Obviously I can’t guarantee results.

2 Likes

ahem

more battery stuff

The reason you don’t have a 65W power bank is because most power banks use cheap cells that don’t have sufficient output.
The one on my unit uses 3200mAh*6 Simplo Technology LC32SD129Q-6 official rating for 71WH (66WH after considering energy loss during voltage boosting). Divide that it means each cell must be able to consistently output 3.7V at 2A. Most off the shelf 1000mA ones feature 3 cells with 12W divided among them, for 4W each cell and at most 1.3A per cell, and even then those units get warm.
My friend spent nearly $200 and got himself a 100W absolute clunker, packing 26800mAh or 100WH of oomph. Although I’m sure he didn’t find much use of it just like I did.

You might be wondering why is those power bank super expensive. In one part lies in the fact that they have an actual battery monitor/balancer that gently balances out the voltage of each cell when charging and make sure none of the cells overdischarge. Then you need the circuit to be able to handle 65W voltage conversion/leveling. Then you need the batteries to be able to handle the 65W of output without exploding. Then you need all of that to be able to take 65W and top itself up in exactly an hour.

There are some 45W ones, if I remember correctly. Like this one

Even though the absolute maximum rating seem to be still 60W. weird.
Anyhow. USB-PD actually have a weird quirk where despite the regulation saying that you MUST supply 20V with at least 2.25A (for 45W), some chargers like the Anker 711 is able to negotiate a 20V 1.5A which, while it makes laptops complain, they will still end up taking it, often times actually charging it up as you use it. Albeit, very very slowly.

1 Like

Not quite. Here’s the requirements table from the PD spec:

At exactly 45 W, 20 V is not required at all. Anything above 45 W does require 20 V.

1 Like

My saying is that in order to supply 20V to the rail the charger must be at least capable of 45W, according to specifications (instead of the 20V at 1.5A like I mentioned) and also as you mentioned, 20V 1.5A worked just fine. However there are not a lot of 30W power banks (if any) that can do the 20V 1.5A.

They do claim that the laptop can charge from basically anything, like a 9V 2A or whatever conglomeration of a “QuickCharge 3.0” nightmare it is.

1 Like

This is not true. The spec does not forbid low-wattage devices from offering additional voltage rails as long as the advertised current does not exceed the source’s max power (see section 10.2.3).

This I definitely agree with. I wish there were some, but so far I have not found any. I’ve been considering building my own, though having the option to force the Framework laptop into 9 V mode would be much easier and meet most of my needs.

2 Likes

There are more 65W than 30W. And some more 45W.
This 30W I found https://www.amazon.com/dp/B07R716V2V/ bumps right up to the capacity limit of 100WH and indeed deliver only a maximum of 30W. But it doesn’t do 20V out.
I still think a 20V output will be handy since basically any other computer is unable to take a 9V/12V/15V input. Although since you have Framework you can have it act like the “power adapter” and charge the other devices

Which goes to show the mightiness when tech work together and engineering/ingenuity that goes into them, and the necessity/benefit of not cutting corners. I had once “jump-started” my father’s Macbook with my Dell because he forgot to bring a charger and I can just continue to use my Dell plugged in because the Dell have both a barrel jack and a Thunderbolt
Whereas my Lenovo T14S decide to fry my Dell instead

1 Like

Thanks @Kieran_Levin appreciate the transparency and clarity.

Sadly, reworking boards is beyond my skill set, but disabling the 15V rail in the BIOS would work for me as well, as the charger I have will output it’s fully power at lower voltages.

I think it’s worth doing, as others have pointed out, lots of atypical chargers (built into wall sockets, in cars, USB power banks) have lower wattage and so max out at 15V. Even if they cannot output their full power at a lower voltage, this would allow those chargers to work, instead of act broken.

Thanks again. Very interesting to see the details behind this issue.

2 Likes

Success!

I can now charge at 15V with 2A or even 3A. Would provide a proof picture but the OLED display of my type C measuring thingy was hard to capture right.

Had to take the whole motherboard out since the transistors are on the back, ram can stay in, storage removed, storage sticker removed, protective sticker on top of components removed, heatsink removed.

Board was warmed up from the other side, then hot air was used to replace it with the correct mosfet (AON6354).

Storage sticker was a casualty, it broke while removing. Given that it’s underneath the SSD I guess it’s no big deal, not like it protects anything.

It was quite scary when I powered it back up, was blinking like me in all types of ways, though now looking back it was probably due to me having the case open (that’s the regular red blinks) and me spamming F12 thinking i would get into bios settings (got multicolored lights from that). After I reinstalled my EFI bootloader (since i originally booted without my SSD just in case), everything was fine.

All in all: I do not recommend this rework to people, it’s too nerve wrecking doing this on my $700 personal motherboard. Ideally this should be a recall replaced under warranty, but I can imagine framework not wanting to do it due to cost, at such an early time in the company’s business. Firmware workaround is probably easiest, but it still doesn’t feel right (45W->27W downgrade).

11 Likes

Hopefully they didn’t make this mistake on too many units is all I can say!

2 Likes

Do you have a hot air work station?

1 Like

Got my laptop recently and it took me a couple days (and a few cables) to realize the charger I was using was the issue. It’s output specifications are

USB PD Output: 5V=3A/9V=3A,15V=2A/20V=1.5A

I don’t have a lot of knowledge of how the negotiations work but is there a reason that the laptop isn’t opting for the 20V?

This charger was only supposed to be a temporary measure until my dedicated charger arrived but the dedicated charger has the specifications:

DC 5V/3A, 9V/3A, 12V/3A, 15V/3A, 20V/3.25A

so I’m worried that might also be fall into the same trap.

Currently, I’m just using a 15W charger. :woman_shrugging:t5:

1 Like

@fishghost How are you determining what voltage the laptop is negotiating with the charger? Because based on those specs, it should never try to negotiate the 15 V mode.

1 Like

Hey @Sean_Greenslade, thanks for checking. It’s just an assumption on my part based on what’s been discussed above and your research with the dev board.

All I know for certain is that the laptop isn’t charging from an Anker device that offers 15V and 20V. But does charge from a smaller charger that offers 5V/9V.

EDIT: Totally could have made incorrect assumptions about the charging device as well.

1 Like

Thankfully the new charger seems to be working fine. Though, it’s little power indicator tells me it’s charging the laptop at 70+W at times so I’m not sure what that’s about either since it’s supposed to max out at 65W.

2 Likes