Videos Calls on Framework - Fans, Heat/Hot/Temperatures


Computer setup
Kubuntu 20.04
CPU: i5-1135G7
I run zoom video calls on the browser (brave, sometimes firefox). It seems like firefox might have better performance than brave.

I’ve been kind of struggling with trying to keep the computer cool when I run zoom on the computer. If I don’t let the fans turn on, then it gets to 80+ degrees YikEs.

When I do settings where I let performance get lower, then the computer gets too slow.

Other observations

  • temperatures seem to decrease significantly when I decrease the window size (maybe up to 8 degrees)? even when I keep my camera on.
  • temperatures seem to decrease significantly when I am not on the tab that has the video call, up to 10+ degrees lower.

What are other people’s experiences with having video calls on framework? What are some suggestions to keep the computer cool and quiet while having video calls?

I can speak for Discord video call usage. I’m on Win 10 with the 1165G7…sorry if that’s not useful for you lol.

On a minimally-altered Balanced power profile the CPU is at an average of 11W and 53C with the fan audible but still fairly quiet.

I have a custom “quiet” profile that limits the CPU to 50% and on that the CPU is at 6W / 44C average. The fan is still on but effectively silent at those temps, with no noticeable slowdown.

My suggestion for you is to play more with the performance settings–one way is to directly modify the PLs using the RAPL interface.

1 Like

Another thing to try would be native Zoom. In my little experience with Zoom-in-browser (on a desktop) it was horribly laggy and inefficient.


I just bought a cooling pad (a quiet one). Hopefully that would help:

The RAPL limits I was playing with in the post you linked is only for the CPU cores. I guess on video calls it’s probably the integrated GPU heating up.

(The limits at intel-rapl0:0 is for the cores. intel-rapl0:1 is “uncore” which is the rest of the chip. I’m not sure what effect intel-rapl0:1 has on the iGPU if any, I haven’t tested it at all.)

Apologies for reviving the thread, I have a similar problem on calls (across Zoom, Teams and Discord) on Slackware. @iamef Where you by any chance able to fix this?
@feesh & @jbch Could you please point me to other resources to do this for myself? Or can you share your config/settings file for the same?

this is a tough topic in general. the short answer is: you need hardware acceleration enabled in whichever app you use for calls.

  1. zoom (the app) should have hardware acceleration because it’s essentially something that downloads and streams videos using system libraries. this possibly applies to other non-electron apps (e.g. skype but not discord)
  2. browser-based calls are hardware-accelerated if and only if you managed to configure hardware acceleration for your browser. firefox has a few flags you need to set (i used the arch linux guide). to test this just search for your favourite 4k video on youtube (costa rica 4k? :wink:) and monitor intel_gpu_top and check for video activity.
  3. similar tutorials could be used for chromium, personally i didn’t manage to do the same on chrome. potentially chromium flags could be exported to electron apps, e.g. slack or discord, but i don’t use these much for calls so i haven’t tried.
1 Like

Thank you for the response.

  1. I have this enabled on Zoom, but I continue to face the problem. Without thermald installed, Zoom would take about 15% of CPU and with thermald it goes upto 25%. RAM usage is farily low at around 2%. Electron apps or otherwise seem to make no difference when it comes to issues with video calls.
  2. I have already followed this guide and don’t have a problem with videos within Firefox.

One thing is that Intel and AMD silicon run hot when doing any kind of workload. While it is commonplace for us today, video and audio calling is CPU and GPU intensive. It does not surprise me that you are needing thermal cooling in order to keep temps down while video conferencing. I don’t believe you will see a great difference when using any other kind of video conferencing. Especially if that video conferencing is trying to use the full 1080p of the webcam.

I do hope you find some method to reach a middle ground with this though. Out of all of the OSes Linux is the most malleable in this regard, while also being, at times, the most inefficient due to poor drivers and support. (other times it is the absolute best at this.)


This is the challenge, finding the middle ground with these issues. As a person moving from a fairly stable MacOS (where I did not have these challenges while on video calls from the same software), having to tweak around to find the sweet spot is a new task. It is unsruprising that most of the times these are due to inefficient drivers/support or application incompataiblity rather than the fault of the Linux distribution (Slackware) or the laptop vendor (Framework in this case uses hardware from other folks right).

On linux check intel VAAPI hardware acceleration is installed and enabled here :

/usr/bin/google-chrome-stable %U --enable-features=VaapiVideoEncoder,VaapiVideoDecoder,CanvasOopRasterization

With signal desktop it should be slow aswell on linux even with VAAPI :frowning:

1 Like

are you sure videos are HW accelerated? did you do that test? i have no heating issues with calls. if you are positive that HW acceleration is enabled and working then maybe the issue is somwhere else.

vainfo seems to suggest so, is there something I am missing? Or is there a way I can check when I am on a video call if it is enabled? Also realised most of these troubles are related to Wayland, and when I logged in with xorg, much lesser trouble for everything. I don’t know if that is related though.

i said it in my original comment:

on my laptop you should see the video bar jump from zero to 10% and stay there as long as the video is playing. i have experienced the video bar going up for one second and then going to zero (this means it’s not working).

if you’re using stable firefox (older than 102 i guess) you need to enable MOZ_DISABLE_RDD_SANDBOX=1 (blah blah security risk blah blah so make sure you get rid of it once you’re on 102).

Thank you for the patience, apaologies I missed out the intel_gpu_top comment. Intel_gpu_top now shows upto 10% on video and Render/3D drops down to 20-25% (from the previous 100% without the settings that I had already followed from ArchWiki). This is specifically for the costa rica 4k video you had mentioned too.

And on chromium even with

there is no movement on video in intel_gpu_top.

I switched to xorg from Wayland and most of these problems seems to have vanished. So I will stick to it for now, maybe check Wayland in a year or two :-). Maybe I was doing something wrong with Wayland.

just in case you want to retry wayland, this is my ~/.config/chromium-flags.conf. it’s the result of trial & error so don’t ask me why what is working :slight_smile:


FYI copying this to chrome-flags.conf does not work, no idea why :slight_smile: