Windows 11 Pro - Azure AD account setup

We received 2 Framewrok Laptop 13 AMD laptops today and when setting up Windows 11 we have to connect the laptops to Azure AD.

The problem I am having is there is no option in Windows 11 Pro setup when adding a work/school account to select AzureAD (Entra) login.

I can try to connect the normal way of adding a work account and the login details work and then when I select the users account, I get an error ‘oops, Youve lost internet connection.’

I have downloaded Windows 11 Pro several times and created the usb with the Microsoft tool, also tried Ventoy with no joy.

I have setup lots of computers and laptops before and have never seen this before.

I have also reset the bios to optimal defaults and that has not worked.

Also used a usb-c network adaptor but the same and also installed the driver pack via cmd to get wireless but that failed at the same point.

Any advice would be appreciated and thanks in advance


Hi @Mark_Allen ,

You are trying to join the computers to the company domain correct? In past it was a bit easier, though it almost always was done after creating an Administrator account then joining the domain.

If you are trying to join it at the time of Windows 11 install directly to the domain you might need a provisioning package from your Admin. Even more complicated, it may need to be setup on a specific USB drive with the provisioning already done as part of a custom installation script in the installer. Sometimes referred to an answer file in the past.

I just checked on my machine with Windows installed and there is an option at the bottom after going to Accounts → Access Work or School → Connect That shows to “Join this device to Microsoft Entra ID” (which is the new name for AzureAD)

Here is a screenshot I took…

Welcome to the Community, and congratulations on your new Framework Laptops. :partying_face: