Won't boot, how reseting the BIOS?

I have a problem, I tested to switch between the GPU and the “empty” extention, and now my framework won’t boot
Did I miss something ?

I tried removing the battery and wait 10 mins but nothing change…

there is a way to know why ?

are the leds on the side of the laptop doing anything?
did you use the correct interposer?
is it installed properly (try reseating it)?
did you use the battery disconnect function before switching expansion bays?

The only message I can see (it disapear very very fast):

BIOS Version: IFG6.03.02
BIOS build date: 01/03/2024
Processor type: AMD Ryzen 9 7940HS w/ Radeon 780M Graphics
System memory speed: 5600MHz


the led do Nothing
And yes I checked everything

Weirdly I can see a message when something isn’t connected like: Input modules not connected, Input bay extensions not connected, etc… but when I press “skip to boot”
I have always the same problem

Did you try switching back to the gpu module?

You also might re-seat the SSD. I don’t think that you would get to the input modules page if the ram were not seated, but I honestly don’t recall.

If you spam f2 on power-on, can you get to the bios?

Oh ! F2 work !

it’s a weird problem,
my Linux (Ubuntu 22.04.4) partition won’t boot and not exist in the EFI menu…

but the EFI file continu to exist… and say “Reboot”

Okay so now I have a way to check.

I also changed the Timeout in boot for 3 seconds

Because 0 second is too fast, same for my eyes.

And anyone know how can I reset the bios in case of problem ?
or forgot password ?

Or reset the “Password is the same as the previous one” (after testing 3 differents password it continu to backup the password) ?

Thanks for all your support.

There is a guide for the 11th gen, maybe something similar would work Fully Resetting the Mainboard State - Framework Guides

I don’t found the RTC coin cell and I tried to remove the battery but nothing change, just the “clock” was reseted but nothing other.
That’s weird.

The newer Mainboards take the RTC power straight from the main battery

according to framework support you have to plug in AC power, then press and release the chassis intrusion switch 10 times (pressing it for at least 2 seconds, then releasing it for long enough for a red blink)