X,C, and V keys not responding

I have an issue with the keyboard on an 11th Gen Framework that’s almost two years old now. Specifically, the X, C, and V keys are not responding. The issue is OS agnostic; my wife uses this laptop with Windows 10, but the behavior is the same when I boot into Fedora 38 from a USB drive.

My wife noticed the issue first with the C key, probably because it’s in her Windows password (so yeah, we can’t even login to Windows at this point). I’m not sure if the X and V keys stopped working at the same time, or if the issue has spread.

Over the last two days, I’ve twice opened up the input cover, tapped gently on things, rebooted it, and the keys worked again for a while. Now I’m getting nothing. I’ve already tried to re-seat the touchpad cable on both ends, as I saw a reference to that being a possible cause.

I’ll email for support too, but figured I’d ask the community for wisdom in parallel.

External keyboard (USB, wireless, BT) for a quick fix to login. Then change the password.

Any liquid spill recently? Even a lucky drop can corrode a trace. Perhaps some debris. If you don’t want to disassemble the thing entirely you could be heading for a new input cover. If you do, and can’t fix the current one, another keyboard…

1 Like

Fortunately I keep her previous laptop in working condition and she’s a heavy Chrome and Google Drive user with everything synced, so she’s mostly back in business with that one for now. (She noticed the inferiority of the display on her old laptop immediately, by the way; I’ve also found that trying my old laptop again really makes me appreciate my own Framework all over again.)

I wouldn’t rule out a liquid spill but I can’t be sure. I was originally thinking debris under the key when she was complaining about only the C key, but that seems less likely to me when it’s three keys.

Indeed. Debris isn’t likely to move in both directions, but trace corrosion might.

For an update on my situation, in case anyone else has the same sort of problem one day: Support got back to me yesterday evening, requested some photos, and then responded to me again late last night. The recommendation was to just replace the whole input cover; not terrible for $100 and what will take less than a minute once it arrives here.

I have another 11th Gen Framework (mine) and I tried swapping the input covers, and that clearly isolated the issue to somewhere between my wife’s touchpad cable and keyboard itself, so a new input cover will definitely fix it. I guess it’s not worth trying to disassemble the input cover to replace only the keyboard.

This won’t work. I have the -exact- same issue. Replaced the cover. Problem went away for a little while. It’s back. I’m so sick of this laptop. I’ve had nothing but problems; three motherboard replacements and one out-of-pocket out-of-warranty type cover replacement.