12th gen memory compatibility?

I received my 1260p and loaded it up with JEDEC CL22 3200MT/S crucial sticks here;
The BIOS can see that it is “3200MT/s” Ram or it vaguely can run at that speed.
CPU-Z is reporting something in the ram tab I have never seen which is that it is fluctuating between several different JEDEC frequencies between 1066MT/S (533mhz ) and 3200MT/S (1600mhz).
I thought perhaps this was just something to do with Intel’s power management (even though I’m on plugged in power) however, when I run 3dmark timespy (which has built in monitoring) it is telling me that the memory frequency is a rock stable 2666mhz.
This seems to be correct as my 1643 graphics score is several hundred points off notebook check’s

Any idea what is going on here? The kit is JEDEC rated for 3200mhz but, it does not seem to be detected and is being run at 2666mhz.

Are the modules themselves marked as 3200Mhz? The link provided seems ambiguous as to the speed that you would receive, especially since it seems it is being sold by a third party retailer and not Crucial/Amazon directly.

they are 3200mhz, CPU-z reads 3 JEDEC 3200mhz profiles. The link is for information only, I bought these from crucial directly. They are the same p/n as is on the FW compatibility list.

1 Like

Have you tried re-flashing the BIOS with the most current version? Have you tried booting with just one module installed? On the off chance that you have more memory lying around, have you tried booting with other modules?

There are no BIOS updates (or any BIOS) available;

By chance, I do have another set of 32GB 3200MT/S modules of a Samsung variety and, the behavior is the same both with CPU-Z and, Time Spy.

On my first boot it didn’t run at the 3200 MHz speeds but after restarting it was fine for me. Have you already tried re-seating the sticks and also run a memory test like OCCT to rule out any problems there?

Also, I’d use hwinfo64 to monitor and log your memory clocks accurately (the log you can send to Framework support as well if you need to go them if you can’t find a solution on your own first)

I am seeing the same issue with unusual fluctuations in memory timings. I’ve run memtest86 and it reports no issues with the memory supposedly running at 3200, BIOS shows 3200MT/s, Windows task manager reports the memory running at 3200MHz, and yet CPU-Z and HwInfo both show strange clock speed jumps and changes in latency/timings.

Admittedly I went outside of the recommended spec - so I know, I only have myself to blame - with 2x sticks of Kingston KVR32S22D8/16 strangely the 32GB sticks are listed as compatible but the 16GB sticks are not… Again, I should’ve known!

I’ve not encountered any unusual behaviour, so perhaps this isn’t a problem. It is weird though. I have a single stick of (compatible) Crucial memory, so I shall see if that produces similar results.

1 Like

Just to follow up on this…

I have since tested with a single stick of Crucial CT16G4SFD832A (listed as compatible) and the I see the exact same issue in CPU-Z. CL fluctuated between 15 and 19 and frequency was all over the place, but never did it show up as 1600 (3200) CL 22 - which is what the module is rated as.

I’ve not experienced any noticeable issue on Windows nor Linux, so I’m not sure what is going on exactly as the system seems stable. Perhaps this is something to do with the way CPU-Z/HwInfo read these data?

It would be interesting to know if other 12th Gen users are seeing similar, and whether this existed in 11th Gen models.

My 1280p Framework does the same thing. I have 2 16 GB Fury 3200 CL20 that has a JEDC Profile as well (KF-432S20IBK2/32)
I see the same behavior. I assumed it was just the system using the memory at the speed it deem necessary. Like the CPU doesn’t always run 100%. If not the case it would be nice to know if there is a fix for it in the next BIOS update.
I am running Windows 11 Pro on the latest updates.

@RandomHandle I have ordered the same memory (2 sticks of Kingston KVR32S22D8/16) for the 12th Gen model - lets see how it works for me. Have you tried running 3D Mark (as mentioned by @Andrew_Phillips) or something similar to see whether the memory performance roughly fits that of memory at 3200MHz?

Hi @Friedrich_Burger

In Windows 10 both 3DMark and OCCT show my module speeds at 1330/2660. That being said, the 3DMark performance scores were good in comparison to similar system specifications.

In Fedora 37 both dmidecode and lshw show the clock speed at 3200.