12th Gen screen glitching

I recently received my 12th Gen laptop, and have been having an issue I couldn’t find anything about when searching:

Every 20ish minutes the screen will glitch for a split-second. Sometimes this involves the entire screen going black, sometimes it involves just a portion of the screen that gets displaced and discolored. This seems to happen and then go back to normal all within 0.1s or 0.3s. It’s reminiscent of a desktop monitor being connected with a bad display cable.

Is this a documented or known thing with the 12th-Gen Framework that others have run into?

Thank you,


1 Like

Which OS are you using?

1 Like

Have you tried reseating the display cable to the main board?

I guess a connection issue should appear more often than just every 20 minutes though…
Still always worth a try!

I’m having the same exact problem with my 1260P mainboard. I upgraded from an 11th gen. I spent the past week troubleshooting with no success. Now that I have confirmation someone else is having the same problem it’s time to reach out to support. I suggest you do the same if you haven’t already.

1 Like

Thank you for the responses

  • OS is Windows 11, 21H2, build 22000.856
  • I had not touched the display cable at all, wanted to research first

At the time of opening this thread, I had not yet installed the chipset drivers from Framework Laptop BIOS and Driver Releases (12th Gen Intel® Core™)

After having now installed the chipset drivers, this issue has seemingly gone away. @CJ_Elevated Hopefully this might help you as well

1 Like

Looks like a panel self refresh issue. On Linux it is solved using i915.enable_psr=0, but recent kernels seem to work fine without the tweak.

Maybe Windows has something similar. Just note that that would somewhat affect the power consumption.

I installed the driver package, but I’ll try a reinstall and see what happens.

@CJ_Elevated You might have to uninstall the old drivers. BTW, great content

Thank you again to everyone who responded.

As an update, this has not happened again in the days since installing the chipset drivers per my last post above.