3 out of 4 ports no longer working after hard crash

Windows 11 AMD Framework 13 system with 3.03 BIOS hard crashed / simply appeared to power off. On reboot, three of the four ports are not working. Prior (and during) the crash, the setup was as follows:

  • Rear left: USB-C card, monitor connected via USB-C cable
  • Front left: USB-C card, empty
  • Rear right: USB-C card, connected to a USB hub (connected to 60w power which it is passing through) which has HDMI to a monitor, plus a Logitech unified receiver, a webcam, and a 2.5gbit ethernet adapter connected to USB-A ports
  • Front right: USB-C card, empty

After the crash I have tried the following in the RL, FL and FR ports:

  • USB-C card with power (laptop registers not charging)
  • USB-C card with C-to-A adapter and a USB flash storage device connected (no storage device registers)
  • USB-A card with USB flash storage device connected (no storage device registers)
  • Ethernet card (no network device registers)
  • USB-C card with Thunderbolt cable connected to monitor (no display registers - I sometimes see the message “Display connection might be limited” near the systray)
  • HDMI (gen3) card with monitor connected (no display registers)

I have tried alternating the USB-C cards into different ports to rule out one or some of them being faulty.
I have looked at Event Viewer and there is nothing I can see logged at the point of the crash, only an entry on reboot.
There are no disabled devices or devices with a warning in Device Manager.
I tried re-installing the AMD drivers and rebooting, no difference.
Therefore I only have one working port - RR. Everything works in this port.

Have you tried shutting down, waiting a minute (perhaps even disconnecting the battery) before starting the device again?
Simply rebooting can sometime leave hardware components in weird states because they are never turned off completely.

Disclaimer: I do not have a FW laptop yet, this is just from my experience with laptops in general.


Thank you for your suggestion.

I disconnected the battery, waited, then reconnected.

I am now being asked for a BitLocker recovery key, which is needed because the Secure Boot policy has unexpectedly changed. As far as I can remember I was not given / asked to save this during Windows install. I did not install using a Microsoft account.

So now I cannot use the laptop at all.

However it did seem to fix the issue with the ports, as I can now charge in any of them and USB devices are recognised.


:astonished: that’s unexpected. Hope you can recover Microsoft support page

1 Like

It is supposed to be saved to your Microsoft account automatically. If you used a workaround to avoid siging in to a Microsoft account, which is required for installing Windows 11, that would explain it.

1 Like

This is highly unfortunate, and a similar thing happened to me on Windows 10: BitLocker was enabled without notice, and there was no account associated to which the key had gone. I booted into a Linux LiveUSB once and my data was permanently gone.

I hope you have not lost much important data.

Progress, but at a cost.

I had a similar issue after performing the 3.03 bios update on my 7840U from Windows 11 pro.

After the bios update finished, the computer looked like it was going to restart and the screen went black but the power button LED stayed lit. After a few minutes I hit the power button and it powered down. I powered it up with my TB3 docking cable in the left rear port and a USB-A hub in the left front port, and a USB-A wireless mouse dongle in the right front port and none were recognized in windows, despite plugging and unplugging a few times. I determined that a USB-C 65w power supply wasn’t recognized in left rear either, but it was in the right rear (so the only port working was right rear). I shut the laptop down, removed all of the ports and replaced them, and then booted up without any USB devices plugged in.

And then, upon re-plugging my USB-A devices they worked. On first plug in the left rear, my Dell TB16 docking cable was providing power to the laptop, but none of the two external displays were recognized. After unplugging and powering off the TB16 and holding down the power button on the dock for about 20-30 seconds, and then connecting to power again and then plugging in the cable to the left rear port, it recognized my displays, but the docking station isn’t providing power to the laptop, so I had to plug a power supply into the right rear port. I may have to start a separate thread about that.

What is this & how do I find it so I have it when/if I need it?

1 Like