Adaptive Brightness Won't Turn Off

I’ve been putting up with this issue for a while, but it’s been bugging me a lot so I’ve finally decided to say something. I have a DIY edition with an 1185G7, and on Windows I cannot for the life of me get adaptive brightness/contrast to turn off.

I have disabled “Change brightness automatically when lighting changes” in Windows Settings. I have disabled Local Adaptive Contrast Enhancement and Adaptive Brightness in the Intel Graphics Command Center. And yet, seemingly at random, the display will get brighter or dimmer.

I keep my display at low brightness, but it rather suddenly dims down to an unusable level, so I turn up the brightness, and a few minutes later it brightens up and I have to turn it down again. I am extremely frustrated at this point and have no idea what to do.

Hi and welcome to the forum.

Which version of Window do you have.

Have just enabled it to see what happens as I have never used it.

I think the sensor is to the left of the camera switch, you could try covering it and then you will know if it is a sensor issue or just software.

The thing is, even if there was a sensor issue, disabling the feature entirely should… you know… disable the feature? The light sensor works correctly by the way, I tried the adaptive brightness when I first got the laptop and didn’t like it.

Yes it sounded horrible so didn’t try it.

Waiting to charge my Framework and will watch some catch up TV.

With an LED behind me that I can use. On my phone it works fine.

Let’s hope when I disable it, it really does stop :slight_smile:

Ok I’ve enabled it but nothing happens, the screen is constant, not a flicker, not a change, well if there is I didn’t notice.

OK so disabled it and the screen became brighter.

Ok further on/off it seems to be working though far too bright in the dark

Don’t quote me on this, but try looking into the Intel Graphics Command Center. There are a couple options there that had been rather annoying, since they adjust brightness.

I’ve had some issues with this recently related to Intel Graphics Command Center where the feature was reenabled in Intel Graphics Command Center but didn’t show up in System Settings, so definitely check there if you have it.

Read the original post. I turned those options off.

Just checking but the option for adaptive contrast is also disabled in Windows settings? That was my issue specifically, “Help improve battery by optimizing content shown and brightness”

As I said in the original post, I turned it off as well.

1 Like

Small clarification on my end, the feature is actually called “Content Adaptive Brightness Control”. I only ask because you only listed three settings and there’s technically four toggles between Intel Command Center and Windows settings. Both have a separate adaptive brightness control setting that’s reflected in the other, otherwise there’s also a Local Adaptive Contrast Enhancement in Intel Graphics Command Center, and Content Adaptive Brightness Control in Windows settings (it’s not called out as such until you click “learn more”, because Windows and redundant, unintuitively presented, user-unfriendly features, name a more iconic duo… ). The latter two are different forms of adaptive contrast/brightness as far as I can tell.

I should clarify I’m on Windows 11, so it might appear differently than you (because Windows and inconsistent naming conventions between versions… you get the point).

If they’re all disabled, I have no clue. Those are the only three/four settings I have found that produce this behavior.

Yeah they’re all off, and the Windows 11 one isn’t on W10. No idea why it still happens.

Have you tried disabling “enhanced power saving” in the intel graphics command center? This is another setting that changes the screen brightness automatically to save energy. It is located in the “System” section under the “Power” tab.

If that doesn’t work, I do remember seeing a thread a long time ago that mentioned a solution that required using the command line to disable a hidden windows option for adaptive brightness, I’ll try to search for it to see if I can find it again.

Well, I scoured the forums with every search term I could think of, and came back with nothing. Either I was imaging the post I mentioned previously, or it has since been deleted. Searching the greater internet I found this article that gives commands for fully disabling windows adaptive brightness that may do more than you’ve already done? (worth a try at least)

Here is the relevant section of the linked article:

  1. Open the command prompt as admin. You can do that by searching for in the Start menu and selecting the “Run as administrator” option.
  2. After opening the Command Prompt window, execute the below command. This will disable automatic brightness when running on battery.

powercfg -setdcvalueindex SCHEME_CURRENT 7516b95f-f776-4464-8c53-06167f40cc99 FBD9AA66-9553-4097-BA44-ED6E9D65EAB8 0

  1. Next, execute this command to disable it when connected to power.

powercfg -setacvalueindex SCHEME_CURRENT 7516b95f-f776-4464-8c53-06167f40cc99 FBD9AA66-9553-4097-BA44-ED6E9D65EAB8 0

  1. Once the command has been successfully executed, close the Command Prompt window.
1 Like

I tried ruining those commands as they are written in cmd in admin mode and it did nothing. I also tried PowerShell in admin which at least recognized powercfg but also did nothing. Am I missing something? It seams to not like the formatting?

This was 2 years ago, so it’s possible that Microsoft removed the ability to do this. I’ve since updated to Windows 11 after upgrading to the Ryzen Mainboard, so I don’t know what else could be done.