Battery Drainage from the I/O ports when shutdown

Hey everyone! New owner of a Framework 13, w/ Ryzen 7840U, here. I have recently found out that this laptop seems to have trouble holding a charger. I have read posts all the way back to 2022 with similar issues.

One of the first things I discovered from others is that the I/O ports (2 USB-C and 2 USB-TypeA) seem to be the issue, so I removed all my ports on the laptop and now it seems like it holds the charge when powered down.

Are there any solutions for this? It is frustrating that I have to plug in the ports, then unplug when I am done with the laptop. I am in talks with support to see what they have to say.

I haven’t been able to really find a solution regarding the Ryzen version of the Framework 13, so if there is a solution please link it to me, thank you.

Ryzen 7840U
Crucial RAM 32GB Kit (2x16GB) DDR5 5600MHz
Windows 10 64-Bit
Mac Book Pro Charger, 100W USB C Charger, Anker Compact and Foldable Fast Charger


Under what condition. Not when it’s powered off surely but yes when on Standby/Sleep.
You don’t say what OS you are using.

There are so many topics on this, I suggest you search, rather than have it all repeated and spread across many topics.

1 Like

SOLVED I solved it by just using AMD adrenalin software to install the AMD CPU drivers. As of currently, it seems to holding the battery charge properly.

1 Like