Blocking at startup on the "Framework" logo


Sometimes, my laptop freezes on the “Framework” logo at startup (boot screen).
I have to keep pressing the power button to force shutdown and restart after that.
I have the impression that it is when it is connected to an external screen (the cover is closed) but I am not sure.
Laptop is connected with Display Port expansion card.

For information, it’s a laptop from Batch 8 with i5.

Thanks in advance.

1 Like

What OS are you using and what is the current version of your BIOS?

I am using Windows 11 with 3.07 bios.


I have the impression that it can be related to an extended standby time.
I still have this problem today.


I want to specify, I waited “a long time” (30/40 seconds) and finally laptop started.
But I don’t think it’s very normal

Thanks !

Is the laptop coming from sleep mode when this is happening? Can you please check & test again?


Sorry for the late reply but yes, it’s happening when my laptop coming from sleep mode.

Thanks in advance.

Your laptop displays the Framework splash screen when coming out of sleep mode?

Is this normal for a Windows machine?

What is the activity on the power led at the side (blinking/steady, color, …)?

I regularly have this problem, since not too long ago. It might be from when I upgraded my 11th gen to the 3.17 bios. I am using linux and this happens when the laptop comes out of hibernation, so I don’t think it’s related to sleep. I don’t often reboot my laptop so I never reproduced it from a fresh boot. This issue happens once every five boot or something, it’s becoming annoying.

Shutting down the laptop and starting it up again fixes the issue and linux resumes from hibernation without any more issues. I tried waiting 10min on the framework logo, but it didn’t move.

EDIT: nevermind, I ran memtest86, and there are a lot of errors, that’s probably the cause. I opened a ticket with support.