BSOD with no dump file on Windows 11 - AMD 7840U

Submitted a support ticket for this issue, but since I’m still waiting I hoped someone else may have an answer. FW13 AMD 7840U BSOD on Windows 11 Pro.

The error that appears is Critical_Process_Died, but it also generates “Dump file creation failed due to error during dump creation” in the event viewer so no dmp files are made. Have repaired Windows, reinstalled Windows, run a memory test, swapped the memory, swapped the NVME, and still the error appears at random. Also experienced hardlocks with no BSOD.

I ran Driver Verifier and was able to get the error PAGE FAULT IN NONPAGED AREA, but that’s it. I do have the dmp’s for that.

Ideas? Or am I looking at an RMA?

RAM tried: G.Skill Ripjaws 32GB 5600 CL40, Corsair Vengeance 16GB 4800 CL40 (running only 1 stick each time)

NVME tried: Silicon Power 2TB XS70 Gen4, MyDigitalSSD BPX 480GB Gen3


1 Like

Assuming you can rule out some Windows software (I assume you run a fresh install, no strange drivers or antivirus installed?) and it seems you can rule out an SSD or RAM problem, then, yes, that looks bad. Might be a bad solder joint on the CPU or some other mainboard problem. I’d expect an RMA, but let’s see what the support says.

1 Like

Have you ran the Framework AMD driver bundle?

Yes, installed the bundle. Once had it crash while installing the bundle too.

Crashes with RAM/NVME combo mentioned above: 1/1, 2/1, 1/2, and currently testing 2/2.

It does seem better with the slower parts, but not sure if it’s because those strain the system less.

Unlikely the case although ram could be a factor what with XMP versus JEDEC. I think at this point, this is something only support can really comment on.

Run memtester to see if RAM is broken.

I ended up replacing the RAM and SSD again, as well as Windows wipes, DDU uninstalls, etc to no avail. Kept getting DPC Watchdog Violations.

Framework is going to replace the hardware. Thanks for everyone’s help!

Is it a case of DOA, or part of the troubleshooting procedure to try?

I believe DOA. No timeline or next steps as of yet.

After almost a month with my laptop, I just started experiencing this as well. I have created a support request as well, but it seems odd that mine is so delayed…

Are you running the latest AMD drivers or the ones from Framework?

Tough to say for completely sure, but I definitely installed from Framework initially, and I haven’t seen anything change there.

AMD’s tool says general software is Driver Version
Graphics is 31.0.14080.3001 released on 9/27 (before the Framework 10/24/23).
Audio is AMD Audio Driver Version

I can pull some others, not entirely sure everything that comes in the bundle.

I am running 64GB of GSkill RAM and a 2TB SK Hynix Nvme (PCI4).

Might be worth trying the drivers directly from AMD. There have been a couple reports of people having their BSOD issues fixed with those drivers. Personally, I’ve been running the ones from AMD pretty much as soon as I got my Ryzen 7 board and I’ve only had 1 BSOD (probably because I’m in the Beta channel).

I suppose that is worth a shot, are you suggesting just graphics? Or the whole chipset as well?

As I type this, it’s been 8 hours of intensive use with no BSOD, of course.

Everything. That’s what I did.