Can someone help me interpret this blink code?

As title says, I am trying to determine the meaning of a blink code as my board will not boot. The BIOS is version 3.07.

I am on this page for reference My Framework Laptop (Intel 11th Gen Intel® Core™) is not powering on

It seems like the order is:
12+ red
1 white
5 green
white/blue?
5 green
more blinking red… I don’t know how this matches up with the listed blink codes. I think it might be “Power boot core VR” - not sure what that means. Bad power supply?? I am currently using a Dell XPS 120W 20V USB-C charger. I have a 65W GAN charger coming tomorrow that I will try instead.

Video of blink code:

In the video, I only have 1 of my sticks of RAM installed - trying to debug what the issue might be. I’ve tried both slots. Tried with both sticks, 1 stick, with and without a M.2 installed. Can’t get a BIOS screen to show.

I know the RAM sticks are good as they were previously inside a Dell XPS 11th gen laptop with no problems.

RAM is: SK Hynix 8GB PC4 DDR4 3200MHz PC4-25600 RAM HMAA1GS6CJR6N-XN 1.2V PIN-260 SODIMM Laptop Memory

I have no operating system installed on the drive - I’m just trying to get the BIOS to show. Ultimately, I’d like to use this outside of the case as a standalone computer.

Looking at the video, you have this:
White (Start of diagnosis)
rgggggrggggg

First red: Battery connected not detected (as expected, no battery)
Second red: Audio board not detected (as expected)
then

Orange (Start of post code section)
bgbgbggg
10101000 (bit 0 to 7)

Flipping that (bit 7 to 0):
00010101

… 0x15 ?

Seems to be:
BDS_PCI_ENUMERATION_END BDS 15 PCI enumeration complete

From here:

So, when you say “as my board will not boot”…You mean you’re not seeing any boot screen on a connected USB-C monitor?

Just a shot in the dark, did you enable the “battery disconnect” option in the BIOS before doing this test? It looked like in your video that you did not have a battery connected to the board, that you were just running it straight from USB-C power. If so, you may have to temporarily connect a battery to get into the BIOS so you can change that option. Hope this helps.

No boot screen, no framework logo, no BIOS.

I just got this board from someone else. I don’t have a battery, case or anything besides the board. Does this mean I have to buy a battery just to enable this setting? It looks like they aren’t currently available to buy :person_facepalming:

That might be the case, I cannot say for certain that is what the code is referring to. I’m pretty certain you have to change that setting if you want to use the board without a battery attached. Perhaps the person you got the board from can use their battery to just check if this is the case.

Wasn’t this no battery thing an issue on older firmware version and they addressed it in later versions? I’ll see if I can find the one…

I only found the mention in the 3.06 BIOS (I feel like I’ve seen it for later ones though…):

There are other posts as well where this is brought up (They didn’t say what version they had…):

Linus also mentioned the issue in this video (And didn’t mention what version he had…):
https://www.youtube.com/watch?v=SYc922ntnKM

In my case I mailed in the motherboard later as RMA and got another one which worked straight away. I never received back an info what was wrong, but I filed it under “dead on arrival” - so I also cannot say which BIOS version was installed. And yeah, I had no battery.

To give an update:

@Second_Coming, I believe you are correct in interpreting the blink code. It seems the device was booting properly.

BUT, the board does not pick up the external display.

You have to unplug/re-plug the display for it give output to the external display. Not sure why this is… maybe because it’s trying to output to the internal monitor (that is not connected).

Hopefully there is an update or setting to fix this behavior. I will update the thread if I find a setting to fix this.