Charging Bug on Framework 13 AMD - battery empty, orange led stays on while non pluged

Using a framework 13 amd, i’m encountering a weired bug.
Using the laptop, i ran off battery (2%), and i didn’t had the time to plug in before blackout.
The framework had time to detect the plugin since orange led in on.
But now framework is completely non reactive, impossible to power on, and when i remove the charger, the orange led stays on !!
Acting like the chatging hardware failed and does not recognise charger. Pluging on on the other side does not trigger the orange led (stays off).

I use a 100w PD charger and I curently does not have access to the official charger (nor a screwdriver). i tried a 5V 2A dummy charger without any luck.

I will try to remove the battery when i can.

Any other idea ? Is there a way to trigger a hardware restart of all the components ?

Thank you very much for your help

Framework resucitated this morning
After spending all night not plug in with orange led still on, this morning everything was off, and began charging with my pd charger, and boot.
Problem solved (will keep official dummy charger next time ^^)
Thank you