Daily BSOD issues

Sorry in advance if this is in the wrong place.
I feel like I’ve been chasing my tail with errors and problems ever since I got my system. :frowning: Which funny enough I got to replace an aging Toshiba that was erroring out daily too, because the onboard video was no longer getting driver updates. The near daily crashes are really making it hard to function and I’m officially waving a white flag on trying to solve it solo.

I have explored a number of methods to stop having BSOD errors

things tried
  • removed my hub and external drive
  • switched to logitech bluetooth devices for external mouse and kb just in case my off-brand usb devices were a problem
  • gone down to 1 newer external monitor (after my older dell became perma-stuck in 640x480 generic driver mode) plugged in via an official hdmi expansion card
  • turned off all forms of hardware acceleration I could (in browsers, bios, etc)
  • started using a cooling pad at all times regardless of heat reported by utilities
  • replaced the ram with a stick off the approved list, there were no reported errors, it was just in case
  • ran memtest64 a few times, once for over 24 hours without error
  • started using intel utilities to make sure windows wasn’t shortchanging me on current drivers
  • not used any antivirus but defender
  • not permitting background apps (to the best of my ability, adobe is very greedy)
  • fully updated bios (3.10)
  • run sfc /scannow repeatedly, sometimes with fixes, sometimes without
  • uninstalled and reinstalled drivers
  • disabled all “sleep modes” I could to ensure no crashes on wake up
  • sdd utility reports no errors
  • defender says i’m okay but it’s possible it’s compromised, haven’t run malware bytes but I probably should!

And about once a day I get one of a rotating list of BSOD errors, sometimes preceded by mouse jitters, sometimes not.

  • (corrupt dump) LiveKernelReports\PdcLockWatchdog
System information

Ordered DIY edition March 3rd 2022 - I’m not sure how to determine what batch that is?
Processor: Intel® Core™ i5-1135G7
WiFi: Intel® Wi-Fi 6E AX210 No vPro®

Windows Version 10.0.19044 Build 19044
BIOS Version/Date INSYDE Corp. 03.10, 7/19/2022
SMBIOS Version 3.3
Embedded Controller Version 255.255

Installed Physical Memory (RAM) 16.0 GB
Total Virtual Memory 39.2 GB
Crucial 16GB 260-Pin DDR4 SO-DIMM DDR4 3200 CT16G4SFRA32A
SABRENT Rocket Q 1TB NVMe PCIe M.2 2280

Page File Space 23.4 GB (Manually increased to see if it would stop the crashing)
Virtualization-based security Not enabled

Device Encryption Support Reasons for failed automatic device encryption: WinRE is not configured
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualization Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes

most recent chkdsk and sfc

The type of the file system is NTFS.

WARNING! /F parameter not specified.
Running CHKDSK in read-only mode.

Stage 1: Examining basic file system structure …
1255936 file records processed.
File verification completed.
Phase duration (File record verification): 11.26 seconds.
9630 large file records processed.
Phase duration (Orphan file record recovery): 0.00 milliseconds.
0 bad file records processed.
Phase duration (Bad file record checking): 0.26 milliseconds.

Stage 2: Examining file name linkage …
875 reparse records processed.
Index entry fࡦmpeg.dll in index $I30 of file A1657 is incorrect.
1718266 index entries processed.
Index verification completed.
Phase duration (Index verification): 38.55 seconds.

C:\WINDOWS\system32>sfc /scannow

Beginning system scan. This process will take some time.

Beginning verification phase of system scan.
Verification 100% complete.

Windows Resource Protection did not find any integrity violations.

The ffmpeg.dll issue in the chkdsk results is new. So is the Store Data Structure Corruption error.

Also I started writing this on Wednesday, decided against posting it, and today I’ve had to run SFC and DISM after my system menu became inaccessible unexpectedly. Then a minute ago I got another page fault BSOD.

At this point my plan is to back up all my regular files, browser prefs, etc and wipe the whole machine, start over. While I was writing this, I got an IRQL not less or equal BSOD.

This is getting kind of difficult to deal with!

I wonder if the SSD is at fault here.

1 Like

It’s possible although Sabrent’s own utility reports no issues. Haven’t done a deep dive on what a better tool might be to check for integrity violations. Specs wise it’s in line with approved vendors afaik.

If you have another SSD, maybe give that a try.

If not, maybe try using a Live linux USB for a couple of days (without the SSD installed)…see if a live linux environment is functionally stabler, and should give you additional indicators whether it SSD related. (because we know, Windows 10 and 11, OOTB, if installed correctly won’t give you those errors that frequently…so it’s not really the software, and therefore changing OS shouldn’t matter in this case)

1 Like

I would run memtest on the RAM, and if that does not show an issue replace the SSD. My bet would be on bad RAM.

1 Like

OP already did.

For a system with 16GB RAM, ran for 24hrs…that’s at least 3 rounds.

Missed that.

Might sound basic, but have you tried removing the RAM module and reseating in Slot 0 given that you are only using one module? Also, we’ve seen some wonkiness if the SSD isn’t inserted all the way. You can try removing the SSD, checking the connection, and then reseating it as far in as it can go to make sure it’s fully seated in the connector and then using the screw to secure it to the mainboard.


Will try unseating and reseating both. Stability loss has been progressive over time. But otoh a little error here and little error there from connection issues could add up to progressive failures.

Update: Swapped slot on RAM from 0 to 1. (Does it matter which slot when there’s only one? I didn’t find a definitive answer and most of the discussion was about desktop hardware.)

The SDD did have a tiny bit of gold showing! I took it out and reseated it, no gold. I may have been overly gentle and overlooked that as a potential issue since the screw lined up well enough to lock in. This style of drive is pretty new to me and every board slot is unique in what constitutes secure so I didn’t think anything of it.

Will have to wait and see, since I didn’t find a reliable way to force a crash for testing purposes.

@Georgene_Nunn Yep, no gold should be showing on the connection end of the SSD as it should be under the shroud. There’s a very good possibility that’s causing your issue. Also, if you are only using one RAM module, it needs to be in Slot 0.


Could it be a bluetooth issue? I’ve been having no trouble with my 12th gen DIY i5 (running Linux instead of Windows though), but when I tried using some bluetooth headphones for a few hours, at some point the machine locked up and needed a long press of the power button. Since then I’ve been avoiding bluetooth. Maybe try that for a few days if possible,

1 Like

Yesterday no further crashes after the swap and reseat. This morning it behaved very erratically when I turned my monitor on after boot up. Had to hard shut down due to unresponsiveness. So I took the opportunity to swap the ram back to slot 0.

I think reseating the drive is likely to be the solution to the core problem, but I will likely have to back up, wipe, and reinstall, since I don’t especially trust windows to fully recover from the instability caused by the crash-happy period. That said, if I go 2 days without another BSOD I’d say that got it solved. If not I may move on to live linux and/or no bluetooth.

I doubt it’s possible to adjust future board models to be more strict about how the support screw lines up so the drive has to be fully inserted to be secured, but it may be worth making a note in documentation that none of the gold should be showing (unless it’s already there and I overconfidently missed it). It’s not necessarily self-evident - with RAM, for example, there actually is a tiny bit of the contact area exposed and that’s… normal? Or at least no matter how snugly I try to insert it, it remains visible. I seem to recall that being fairly standard for RAM and (incorrectly) assumed it was fine for the stick style of SSD as well!

Just BSOD’d. Memory Management. Was afk for maybe… a half hour? and the moment I sat down it dropped into BSOD. This time with a little bar across the top, glitchy colors, and it wouldn’t restart after hitting 100%, it sat there with the fan running.

SFC didn’t find anything. I’m all ears for other things I should check.
Honestly I think I’ll have to up my timeline for backing up, wiping, and starting over.

In my experience (I’m strictly a Dell repair tech, so YMMV):

I have repaired desktop machines that were randomly displaying BSODs with different errors - including several of those mentioned in the OP - by replacing the processor.

This was after replacing the system board and sometimes the RAM (at the very least a RAM dance was performed, exonerating it).*

I also repaired laptops behaving like that the same way. More and more that means replacing the system board (which sorta partially exonerates the processor, making the whole issue messier…).

It sounds to me like you’ve done everything you could possibly do, and more than Dell would need in order to have me replace the CPU.

So if I had to guess… you may be heading for a motherboard replacement.

* For a while it happened so often I created my own little conspiracy theory:

As a hardware resolution to the Spectre and Meltdown bugs, the CPU manufacturer sent out BIOS updates that purposely faulted the CPU, requiring it to be replaced with one that doesn’t have them.

I concocted this little fantasy because, in my initial training the processor was emphasized as absolutely the last component to be replaced, because it was the hardiest thing in the computer. Then a couple years after those bugs appeared it seemed like I was suddenly replacing desktop CPUs left and right.

(Disclaimer: This is entirely for my own amusement. Nobody should take it seriously - I certainly don’t.)

ATTEMPTED_WRITE_TO_READONLY_MEMORY - this error occurs if a driver attempts to write to a portion of memory that has been designated as read only.

If you haven’t yet, make sure you’re on the latest BIOS and that you’ve got the latest drivers directly from Intel’s website.

If you have other USB based devices usually plugged in remove them one at a time and see if it resolves.

Just to not leave this hanging with no updates, had a migraine weekend so didn’t get a chance to start fresh like I hoped.

BIOS is 3.10 as noted in OP. USB items plugged in are: monitor via hdmi expansion card, power via USB-c expansion card, fan via USB-A expansion card, and one unused USB-C expansion card. Crashes have occurred in nearly every configuration.

(I have not tried unplugging absolutely everything and running the system long term aiming for a crash, largely because this is also my work computer and it’d make life pretty challenging. I’d also hope for another way to test if basic components were the source of the conflict!)

Here’s a list of the latest crashes.
11-8 memory management "A corrupted PTE has been detected. This is possibly a software problem. This is a typical case of memory corruption. "
11-7 memory management
11-5 system service exception - win32kbase.sys (win32kbase+0x7148F)

Are you able to install nirsoft bluescreen viewer and post the information that results on your next BSOD?

Certainly! I usually use WhoCrashed but this might get more info?

3 recent crash dumps saved from BSV

Dump File : 111722-8000-01.dmp
Crash Time : 11/17/2022 4:49:22 PM
Bug Check Code : 0x0000001a
Parameter 1 : 0000000000041792 Parameter 2 : ffffd33fff0363c0
Parameter 3 : 0000100000000000 Parameter 4 : 0000000000000000
Caused By Driver : ntoskrnl.exe
Caused By Address : ntoskrnl.exe+3f92d0
File Description :
Product Name :
Company :
File Version :
Processor : x64
Crash Address : ntoskrnl.exe+3f92d0
Stack Address 1 :
Stack Address 2 :
Stack Address 3 :
Computer Name :
Full Path : C:\WINDOWS\Minidump\111722-8000-01.dmp
Processors Count : 8
Major Version : 15
Minor Version : 19041
Dump File Size : 2,380,004
Dump File Time : 11/17/2022 4:49:55 PM

Dump File : 111722-18859-01.dmp
Crash Time : 11/17/2022 12:18:26 PM
Bug Check Code : 0x00000050
Parameter 1 : ffff828a64b163c8 Parameter 2 : 0000000000000000
Parameter 3 : fffff8064fa0ef66 Parameter 4 : 0000000000000002
Caused By Driver : FLTMGR.SYS
Caused By Address : FLTMGR.SYS+28060
File Description :
Product Name :
Company :
File Version :
Processor : x64
Crash Address : ntoskrnl.exe+3f92d0
Stack Address 1 :
Stack Address 2 :
Stack Address 3 :
Computer Name :
Full Path : C:\WINDOWS\Minidump\111722-18859-01.dmp
Processors Count : 8
Major Version : 15
Minor Version : 19041
Dump File Size : 2,427,532
Dump File Time : 11/17/2022 12:19:13 PM

Dump File : 111622-19515-01.dmp
Crash Time : 11/16/2022 1:04:56 PM
Bug Check Code : 0x1000007e
Parameter 1 : ffffffffc0000005 Parameter 2 : fffff8006610c910
Parameter 3 : fffff18719a6e998 Parameter 4 : fffff18719a6e1d0
Caused By Driver : FLTMGR.SYS
Caused By Address : FLTMGR.SYS+8b10
File Description :
Product Name :
Company :
File Version :
Processor : x64
Crash Address : fileinfo.sys+c910
Stack Address 1 :
Stack Address 2 :
Stack Address 3 :
Computer Name :
Full Path : C:\WINDOWS\Minidump\111622-19515-01.dmp
Processors Count : 8
Major Version : 15
Minor Version : 19041
Dump File Size : 2,581,420
Dump File Time : 11/16/2022 1:06:02 PM

A note - after I got the system thread exception, I ran chkdsk, sfc, and dism. All found and fixed errors. Didn’t even get a whole 24 hours before it started bugging out again!

I’ve had a mix of work deadlines and seasonal migraines so actually doing a system wipe hasn’t been an option. :frowning: Tho I am open to suggestions on the best method for wiping and starting over once I can carve out the day to make sure I’m super backed up and have time to get all my software set back up! I haven’t had to do a full system wipe in a bit and last time I was able to use 2 drives in the same system to shuffle things around.

Hi @Georgene_Nunn,

We’d definitely recommend a wipe and a fresh install of the OS and the Framework Driver Bundle only as it seems either something is corrupted in storage or something is wrong with the SSD itself. With a fresh OS install, you’ll eliminate most other potential sources of the BSODs. If you continue to have issues with the bare minimum installed, all signs point to a SSD failure. If under warranty, it will be replaced.

Understood. SSD is a Sabrent drive purchased thru newegg. Doubt I have any coverage. Man, what a rough go.

Earlier I turned on my attached monitor and the whole system went unresponsive. Two core windows processes, the desktop window manager and windows explorer, were each using a big chunk of cpu and reported high power use. Whole system’s just sort of wigged out. Tho I’ve had display specific issues almost the entire run of the laptop so far.