Driver issue installing windows on amd version

Hi friends !

I just got my framework 13 DIY amd and I wanted to install windows 11 on it.
I followed the guide that covers this exact procedure and ended up stuck on booting on my usb stick.

Either I flashed my USB with rufus (exactly as advised in the guide) and my USB stick straight up don’t appear in the Boot Manager like so:

and when I use my usual tool (disk from gnome) the bootable device show, i can go as far as the “Install now” screen. But when i click on “Install now” after a few second this warning appear:

I tried:

  • reflash and reboot on another usb stick
  • redownload the windows 11 image
  • windows 10 image
  • the 4 possible usb-A port on the laptop
  • usb-c stick
  • some obscure things i saw on stackExchange

I don’t have any more ideas and I feel pretty much stuck.

I’d be very grateful if someone could give me an explanation (or even a solution?).
PS: if you need any information that I haven’t provided, please don’t hesitate. (help!)

Thank you for taking the time to read me and I wish you a very good day.

Sounds similar to this thread, take a read through - [SOLVED] Help - Windows install via USB-C flash - #23 by Eclectic

1 Like

Definitely helped!
Everything works perfectly now.
The winning combo was to test with yet another USB key :sweat_smile:

I used rufus (on windows) to flash the key with all the default settings.

Thank you !

1 Like